[TIP] Getting RGBW Bulb LZW42 Working in Vera

After including the bulb into your z-wave network, please proceed with the following steps:

Click on the arrow next to the device in the “Devices” screen.

Then click on the “Advanced” link to edit the devices advanced settings.

Next, replace the text in the two marked text fields with this data:

device_file: D_DimmableRGBLight1.xml
device_json: D_DimmableRGBLight1.json

Note: I’ve been told that the following strings add additional color temperature options but haven’t been able to test them.

device_file: D_DimmableRGBLight2.xml
device_json: D_DimmableRGBLight2.json

Lastly, we need to reload the z-wave engine. If your device has disappeared from the “Devices” screen, don’t be alarmed. It will reappear once we restart the engine.

Click on “Settings” on the left side menu, and then Z-Wave Settings.

Finally click on the “Advanced” tab and “Reload Engine”.

Thanks for putting this in writing @EricM_Inovelli. One thing I wanted to note was the it may be optimal to use D_DimmableRGBLight2 as described on the Vera forums here, in order to support white temperature.

Is it that you have the color temperature on the main device page? If I click on the device it does have color temperature with D_DimmableRGBLight1.

I can’t absolutely confirm since my bulbs are all on zwave2mqtt now (and working beautifully), so take with a grain of salt. When I had them on the Vera, the RGB colors worked just fine, but even though the color temp slider appeared, it didn’t actually do anything to the bulbs when I changed it.

I also just recalled that after a power loss, I had to go back into Vera and re-apply some of these settings. Certainly nothing to do with the bulbs themselves, but that was unexpected.

1 Like

Replying to confirm that this works with the new LED light strips. It didn’t work until the 3rd time I paired it and let it set for ~5 minutes before starting to change things.

Here is my experience with it:

I’m using D_DimmableRGBLight1. D_DimmableRGBLight2 didn’t seem to have any different interface for the colors, other than changing the look of the on/off control on the device control page.

I have On/Off buttons, an intensity slider, a ‘warm white’ bar, a ‘cool white’ bar, and a color selection box (all but the on/off are seen in the 2nd screenshot on the initial post here).

On/Off and intensity work as expected. The color selection box works as soon as you click out of it after selecting a color, adjusting the RGB LEDs and turning off both white LEDs.

The white bars work OK once you understand what they’re doing. For the warm bar (1st, redder):

  • If you click on the very left the warm LED and RGB LEDs will turn on at “full” intensity.
  • As you click farther to the right on the bar, the warm and RGB LEDs stay on at “full” intensity and the cool LED begins turning on brighter.
  • Clicking on the far right turns on both white LEDs fully.

(“full” intensity meaning as fully on as the primary intensity slider is set)

The cool bar (2nd, bluer) works similarly, with the cool and RGB LEDs always on and the warm LED increasing in brightness as you click farther to the right (note that this is opposite of the color of the bar!). You cannot adjust the two individually. Also, the RGB LEDs are always on in both cases. Once you make a selection and click out, there will be little map icons on each bar, showing what level each white LED is at (warm in the 1st redder bar, cool in the 2nd bluer bar).

2 Likes

Thank you for posting your experience in Vera.