Unable to update red gen2 dimmer firmware via hubitat driver

I’m just testing out a hubitat and LZW31-SN for the first time. My switch was included and is controllable via the hub, but I was unable to set the LED status indicator via hubitat. I tried a factory reset and got back to the same point. After that, I thought maybe it was worth a try updating the firmware, but I could not get that to work either. I do not have a windows PC or z-wave stick, so I’ve only been able to try using the driver script via hubitat.

When I attempt to update either the target 0 or target 1 firmware with the binaries from the 1.48 release, I immediately get to the ‘please wake up your sleepy device’ status, and no other progress is reported. getVersionReport also does nothing for me, and trying ‘clearLock’, ‘abortProcess’, physical air-gap switch, all seem to have no effect. I also tried the ‘old’ version of the firmware updater driver but it did the same thing.

Any ideas? Is there any other way to see what FW version I currently have?

I don’t know Hubitat, so I’m speaking generally. Settings like the LED color are typically exposed to the hub via the Device Driver, not the firmware. 1.48 is currentl so I’m not thinking it’s the firmware.

Did you install the Hubitat Device Driver? Take a look here:

1 Like

On the device page check if you have the “Create LED Color Child Device” option enabled. This will create a “Component Device” typically matching the original switch name, but with “(LED Color)” at the end.


The LED Color device page will look something like this:

You can use Set Color to determine the LED color and On/Off to determine if that color is used. When the switch is off the LED Color setting on the parent device is used. When the child device is On the color set for the child device is used.

Oh, thanks a lot @Bry - I was not using the right driver. There is an Inovelli Gen2 Dimmer driver that comes with Hubitat, and it partially works, so that threw me off. After switching to the new driver I can control the LEDs.

I’m still not sure why the firmware updater didn’t work for me (see sleepy device problem above). I can confirm that the new driver reports my firmware version to me as 1.48 so I won’t bother messing with the updater any more.