VZM31-SN repaired switch failure with update to 2.14

Hi All,

I had 3 switches fail when updated to 2.14. That is 3 failures out of 15 updates. And I still have 25 to go. The switch still responds to the network prefectly. But the voltage output of the switch is a little low resulting in the lights not working? The exception being some small LED disc lights.

These failures are odd. They have only occurred in 3 locations. Garage, basement, and work bench. What these locations have in common, is they are 90% signal repairs, and they are powering LED retrofit fluorescent tubes, ballast bypass.

I experimented with the basement switch. Voltage output of the switch in on/off mode was 107V, when the input was 120V. This is odd. When placed in smart bulb mode, the 2 small LED disc lights worked. But the fluorescent tubes did not. I tried switching between simulated 0 and 100% and relay mode. But there was no change.

80% of my switches are repairs. So I am nervous to keep replacing. I only have 15 new in box switches remaining from the recall.

I was theorizing that these are my highest current light sources. The basement lights pull 186.5W. The garage would be something similar. And the work bench would be much less.

These failures are all tied to the v2.14 firmware upgrade. So hardware failure just doesn’t make sense.

Any ideas?

All the lights have a neutral.

Swapping in a new from factory replacement switch resolved the issue.


Do you have a neutral at the switch? If so, try using on/off full sine wave mode.

Yes there is a neutral. Are you referring to this option?

In neutral on/off setups, the default is to have a clicking sound to notify you that the relay is open or closed. You may disable this sound by creating a, “simulated” on/off where the switch only will turn onto 100 or off to 0.

Because I tried both.

What hub? There was a scaling issue on some drivers going from 0-100 vs 0-254, so max output was being set at 39% instead of 100%. Could that be the issue? Resolved on ST just last night I think.

Home Assistant. Z2M.

Any suggestions on how to troubleshoot that one?

Are you on edge? The driver had to be updated but has not made it to production yet.

Also, it’s weird that only a few exhibit this behavior, but I’m guessing that is the case.

Also, blues are not rated for ballast/fluorescent loads that I am aware of. LED/CFL/Incandescent only.

2.14 added an option for Full Sine Wave. It’s not in z2m production yet. You can either wait until the May release or try Z2M Edge.


@amurenbeeld is using ballast bypass bulbs. Assuming they are similar to the ones I installed in my basement (LINK) you cut out the ballast and direct wire to 120V. Once I finish all the fixtures I’m going to swap in a Blue.

1 Like

Thanks for clarifying I didn’t understand what the edge comment was above, I do now well, sort of, going to look it up.

The scaling suggestion seems plausible. I’m going to go figure out what z2m edges or just wait for an update.

For now replacing the light switches with 2.08 ones from factory has resolved.

But need to spend some time troubleshooting these switches still.

They are fluorescent tube led retrofits with the ballast bypassed. So they’re basically just LED bulbs.

1 Like

Edge is the beta version of Z2M. It may or may not fully work. That said I’ve had good luck with it in the past. One import thing to note about Edge is that it does not update. You MUST uninstall and reinstall to update.

  1. Copy your config from Z2M
  2. Stop Z2M
  3. install Z2M Edge Addon
  4. Paste in config
  5. Start Edge
  6. ???
  7. Profit :smiley:
1 Like

The full size wave on off looks promising. I will update shortly and let you know. Thanks for the help.

1 Like

No need for this - just add an external converter, copying the most recent inovelli.js file from the zigbee-herdsman-converters repo: zigbee-herdsman-converters/inovelli.js at master · Koenkk/zigbee-herdsman-converters · GitHub

Edit: I should note that we’re getting close to May 1st - Koen usually pushes a new main branch release of z2m on/about the 1st of each month. Probably the best solution for everyone is to wait a few days for the next z2m release and update it when available. It’s the easiest and most reliable way to go. You can track z2m releases here: Releases · Koenkk/zigbee2mqtt · GitHub. I’d expect 1.30.4 will be the next version, unless there are major changes afoot.


zigbee2mqtt 1.30.4 is released, and includes the new converter and cluster definition updates required for making full use of 2.14. Haven’t tried it myself, yet, but will upgrade my installation once I’m home from work.

Thanks everybody for your help. Updating to the latest version of Z2M and selecting Full Sine Wave resolved the issue.

1 Like

Mark solution if resolved please!

I did.

1 Like

Any one know how to get the version number to update in Z2M. The old method doesn’t work.
Dev console.
Endpoint 1
Cluster genBasic
Attribute swBuildId

Error 2023-05-02 13:57:39Publish 'set' 'read' to 'Kitchen Lights' failed: 'Error: Read 0x040d84fffe02bdeb/1 genBasic(["swBuildId"], {"sendWhen":"immediate","timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":true,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Timeout - 17631 - 1 - 110 - 0 - 1 after 10000ms)'