Z-Wave JS inovelli LZW42 is instant on/off

I’ve posted over on HA’s forums as well. Switched to Z-Wave JS and now my LZW42 bulbs instantly turn off/on instead of ramping up/down like they did with OZW. It’s jarring since the rest of the lighting (red dimmers and some zigbee RGBW controllers) do ramp up/down and we like it that way.

Wondering if anyone else has noticed this with Z-Wave JS and HA that might have a solution.

Are you cutting power, scenes, or associations to turn the bulb on/off.

Many are in lamps, a couple are attached to LZW31-SN switches with their relays disabled and associated with those switches. When using the associated switch they still ramp up/down.

It’s only when HA with Z-Wave JS manipulates them do they just pop on/off. So if I manually toggle the entities on/off toggle in HA or a scene/automation turns them on/off they instantly turn off/on instead of ramping up/down like they did by default with OZW.

I’m not sure how else to explain it. Sorry.

Got it. Mine do the same in zwave js. I don’t think the bulbs support dimming unless done via association. Maybe @kreene1987 or @jtronicus know better

They did with OZW beta. I don’t know how they acted with the old deprecated OpenZwave 1.4 as I never used them with it.

Hopefully I can find a solution. We like the ramp up/down.

It doesn’t seem to honor the “transition” setting for light control. Maybe a bug in zwave js?

I saw the transition duration field under multilevel switch. There doesn’t seem to be a way to apply the setting.

I dont think the current version of zwavejs supports transition time/duration

1 Like

Not (yet) supported.

It’s coming though. Thanks @jtronicus for finding that!

yes. thanks @jtronicus I was using the wrong term when I was trying to search for it. I was using “ramp” because I’ve seen it used before. “transition” is what I should have been looking for. We can deal for now. The advantages of ZWave JS definitely outweigh my one gripe.

Hello there, when you say that you associated the lightbulbs with the switch… I used to have that on my older 1.4 Z-wave but with Z-wave JS how to you do that? manage that?


I believe the only way to associate is to use the zwaveJStoMQTT server with the MQTT disabled. It has a user interface that allows access to all the device parameter settings. In HA, you only get access to a subset of the parameters.

Ok. and can I run the zwavejs2mqtt and ant zwavejs addons at the same time?

If yes how do I setup my zwavejs2mqtt to communicate with my z-wave stick without diassociated it from my zwavejs addon?


You can run it instead. It runs the same way as zwavejs runs. I don’t know how you are running it so I can’t suggest anything. I’m running it as a docker container.

Yep if you disable or turn off the ZJS server, you can then turn on the zjs2m integration with the same port callout. Do it all the time.

FYI the latest version of Home Assistant (2021.8.0) now supports transition duration with zwavejs