Z-Wave PC Controller Can't Connect

Having a problem with my version 1.35 dimmer that I believe has been fixed in the new firmware. My first time trying to flash Z-Wave firmware.

Just got the recommended Z-Wave stick from the How-To Article, the Z-Wave.me UZB Stick, ZMEUUZB for North America (where I am). Stick is version 5.2. It’s brand new, arrived today. Appears to be physically undamaged.

I got the drivers installed for it, provided by Sigma Designs and assigned to location “Port_#0001.Hub_#0003”. Driver version from 6/10/2013. Installed on a Microsoft Windows 10 Pro machine running 10.0.18362 Build 18362, which should be the current patch level as of this post.

Got the Z-Wave PC Controller installed (didn’t install the SDK). Version 5.39.

Did a fresh reboot following the driver install and PC Controller install even though it’s not supposed to be required.

But now I cannot get the Z-Wave PC Controller to recognize the Z-Wave stick, even though it detects it:

(It shows up on COM3 or COM4 depending on which USB port I’ve plugged it into, but fails in the same manner on both USB ports.)

When I tell the PC Controller to use the stick I get these errors where the program won’t talk to the stick:
The Z-Wave controller device was not found
and in the status bar:

And as a result, all of the options in PC Controller remain unavailable to me, and I’m stuck at “Select Source”. I’ve never gotten this Z-Wave controller to work, and I’ve never tried to use it with any other program. I have tried a fresh reboot, running the PC Controller as an administrator (made failures fast instead of slow), upgrading my .NET framework (already newest), and moving the stick around to different USB ports (detected as COM3 or COM4).

But so far always the same errors. Any help?


I have now also tried this while all firewalls and antivirus programs were disabled, but no change in behavior.

I was able to get my Z-Way UZB stick recognized and (proably) working under the Z-Way application (released by Z-Wave>Me, the UZB stick manufacturer) running on the same machine. So I think probably the hardware is OK… Haven’t tried adding anything to its z-wave network just yet.

Still not recognized in the PC Controller on the same COM5 port.

Wondering now if I can do the switch firmware updates using Z-Way instead.

Don’t have help, but I did have one computer that failed to load the driver on at all, and another that won’t recognize the USB unless I plug it into a specific port. Don’t know what that’s about.

You are hitting the “detect” button and it’s giving you the information for the dongle?