Z-Wave Range Getting Worse with More Dimmers

I am using a Hubitat C7 with and Inovelli Red Dimmers (“RD”), Black Switches and the Fan+Lights.

As a test I started with 3 RDs back in February. 1 is in the hall right outside the room where my hub is and the other 2 (for the kitchen and dinning room) are down a hall and around the corner from the hub. All 3 got a green light when I added them and there were no problems. They all continue to work with the Hubitat Button Controller rules I created for them. The kitchen and dinning room RDs are in the same 2 gang box.

I was able to exclude/include the kitchen dimmer to remove security. But, I was unable to exclude the dinning room, even with hub reboots (which is another story). So, just for the heck of it I did the range test and the dinning room dimmer is now failing (LED turns red right after a 5 second hold of button C (the config button) has turned green. The kitchen light continues to be green. While literally in the same box, the dinning room one is actually the one closer to hub.

Since originally adding those 3 I’ve added 6 other dimmers (4 RDs and 2 fan+lights) between the hub and the kitchen/dinning room gang box, so the mesh should be stronger not weaker.

Likewise I can’t exclude an Inovelli Black Switch and I’m getting a fail on the range test on it as well even though it closer to the hub, passed the range test when originally included and has a RD in the same gang box that passes the range test, but is on the far side of the hub.

Any ideas of why this is happening? Other than to get a freaking long RJ45 network cord to physically bring the hub closer what can I do?


Did you try running a network heal?


I haven’t as there seems to be a real controversy as to whether one should need to do, or is even wise to, do this. Can it hurt anything? If I do it, how long should I then let the network sit?

Anytime you add, subtract, or relocate a device you should run a heal. The healing process takes ~10 mins on my ~40 device set, but it also confirms the heal is complete. Not sure on Hubitat.

I have seen a few times where I could not Exclude a couple of my devices (Inovelli and others) even on my C4 Hubitat. At some point, I had to perform a hard removal from Hubitat and perform a factory reset on the device. I was then able to re-include them. Not ideal, I know. But at this point, I don’t know if those were device or hub issues.

I ran a Z-Wave repair a couple of hours ago. I don’t know if I need to wait for the mesh to settle like when adding new devices, but I figured it certainly wouldn’t hurt to wait. So I plan to give it a few more hours before I try to exclude/include anything again or even do a range test.

BTW, is this a good idea/necessary? Part of me was thinking that the Z-Wave repair figured out the best path for everything so a wait shouldn’t be needed, but another part of me thought that maybe it “guessed” by pinging devices and started building the network based on that. If the later, it might not be ideal and I was wondering if it might be further optimized over the next few hours. (Though, of course, I shouldn’t have had to do a Z-Wave repair at all since all my devices except 1 plug and 2 Phillips bulbs are mains powered Z-Wave Plus and with a Hubitat C7 hub it should have repaired/rebuilt the mesh itself).

So after I did my Z-Wave repair and waited some 4 hours I tried to do an exclude on 4 devices. The first one, my dinning room, which is in the same gang box as my kitchen light wouldn’t exclude. When I did a range test on it, it failed. I have no idea how this is possible as the kitchen switch in the same gang box passes. And, as I mentioned before, this was one of the 1st 3 I did and I had been doing automations on it with no problems for weeks and weeks.

I then went to another room. All 3 passed the range test. I started with the one closest to the hub. I was able to do the exclude/include with it. I then went for the next one. It wouldn’t exclude. So I tried the one in the same gang box as #2. It wouldn’t exclude either.

So then I tried to do individual repairs for those 3. The dinning room failed but the other 2 passed. I tried to exclude them again, and again they failed. This time though they both failed the range test. So I tried to air gap one and even turn the power off to the room. That didn’t work either. So I tried to repair them both individually. They also failed to repair and both say they are unreachable. I then tried to repair one of them again. It said it did repair so I tried a range test on it right away. It failed. Not surprisingly, it also failed to exclude then.

What can I do now?

I see your on Hubitat. First thing I would do is make sure you don’t have any gohst nodes on your hub. How to remove ghost devices - Devices - Hubitat Next is to power off your hub from the interface. Unplug the power for about a minute and then plug it back in. Wait for the green light, and try your exclude again. With hubitat C-7, if you have any z wave devices that are not plus upgrade them to plus. When you include devices, use either S2 or no security. Depending on the size of your house, it takes about 12-14 devices to have a strong mesh. Just a note, my mesh gets a little flakey about every1.5 months. A reboot from the interface has always fixed the issue.

I had everything at S2 (except one thing that I had made S0 by accident), but have removed all security on all but one device, an Aeotec Smart Switch.

So, I may have resolved the issue by moving the hub about 5’ closer to devices I was having problems with (They said they were out of range). It seems very strange to me this worked as one in particular, which was the farthest of all the problem switches, was one of the first 3 I put in and range wasn’t an issue then. I’m puzzled as the mesh should have grown stronger with more devices, not the other way around.

In any event, for the first time since Saturday, its been > 24 hours and I haven’t had to reboot the hub and everything is working.

As a final note I now have 24 Red Dimmers, 5 Black Switches and 5 Fan+Lights.


Nope! I jinked it. The hub has become totally non-responsive again in that no rules work even though the hub still has a green light. But, this one is resolved. I’ll be hopping back to Hubitat forums for that.

1 Like