ZigBee Fan Switch | Project Zephyr (Blue Series)

Unfortunately you can only do that when the device shows up as a switch in HA. So if you change the device type in the configuration.yaml file like that link showed, it should change that from a light to a switch and then you can tell it to present like a fan.

@MasterDevwi - did you try that exactly as-is, or did you update the ieee with the ieee of your device? You should be able to go to the device page, expand Zigbee Info and grab it from there. Type “fan” didn’t work for me, even with that it changed it to a switch, but I was able to change it from a switch to a fan via the device page.

1 Like

Thanks, I swapped out the IEEE in my config but didn’t for the one I posted here. But I just realized I didn’t include the endpoint number. :man_facepalming:t2: Once I specified endpoint 1 it correctly showed the switch, and I was able to convert it into a fan.

Weirdly, however, the fan only supports on/off, not high/medium/low/off. So I might go back to the old implementation until the device correctly appears on its own.


Check out parameters 97 and 98

Just fyi, The Blue Series Light Switch and the Blue Series Fan Switch are both built by the same manufacturer

If it’s any consolation I 100% did the same thing at first :slight_smile:

I swapped back to the light because I’m using a card on my dashboard with the high/med/low/off options set that way, but was it only allowing on/off via the device or did you try using a different card or google to change it perhaps?

1 Like

Even if that is true, the LED’s are different. Take one apart and find out for yourself. At first I thought maybe the settings aren’t the same, but setting to blue on either ends up being different colors slightly.

I got my switch (!!) and installed it earlier today. Trying to do some automation in Home Assistant and having trouble getting multi-taps on the paddle to trigger. Has anyone else had any luck getting HA to recognize these events?

1 Like

@SamJWard , totally agree.

I have a batch of Blue 2-1 switches from earlier, another batch from the latest run, and now a bunch of fan switches. The LED’s are definitely different, and it’s especially noticeable when the intensity is set high.

My wife and I have been experimenting with what color we like for when the switch is on. At first we tried white, and wow is the white not the same white across the different batches. Then we tried Aqua, same deal, definitely different across the three batches and devices. Even blue was noticeable.

I’m a SmartThings user, so the preferences section for the driver only exposes the color option by name (Blue, Cyan, Red, etc.) and not the actual value. Automations (Rules/Scenes) also use the name instead of a value. I can set the number by using SmartThings’ new advanced api site, or something like SharpTools (I believe), so I was going to tweak ever so slightly the color number up and down until I could get the best match possible.

That’s a lot of work though, plus I had to move most of my switches back to ST’s driver from Inovelli’s after I initially set the parameters. The Inovelli driver is quite large in that it’s supporting both the 2-1 and fan switch, and once I get over ~34 switches, the Inovelli driver starts crashing. That’s something I know the folks at Inovelli and ST have discussed and have provided some recommendations to Inovelli. Hopefully within the next month there will be a resolution. For now though, things are working exceptionally well, and once the initial set up using the Inovelli drive is used, those parameters stay in place when switching back to ST’s driver.

My ceiling fan has an integrated LED light panel and it no longer functions after installing my new Blue switch, whether the fan is running or not. I don’t use it, but figured it was worth mentioning just in case someone thought their ceiling fan light would still function.

It seems to be an issue with ZHA on Home Assistant, as my button presses are not recognized in Home Assistant either.

I’m also having an issue with the dim up / dim down function. I’m running my switch with no neutral wire and I am not able to adjust the fan speed from the switch directly. I’m relying solely on the light entity that is created in Home Assistant. I’m going to try a factory reset later today to see if that corrects my problem.

If you have a non-neutral configuration, then your light and your fan are controlled together through the switch. The fan switch wasn’t designed to control the fan and light together. I don’t know what side effects that might cause, but it’s possible any wonkiness is attributable to that. Since you don’t use the light, I’d consider removing the connection to it in the fan to see if things improve.


I would 100% do that, but I live in an apartment and would need to re-install the light before moving out. I’ll see how difficult it is to do. I don’t mind the wonkiness (there’s a lot more of it going on in my apartment other than the switch), but figured I should mention any and all issues I’m experiencing since the switch is brand new. As long as I can turn my ceiling fan on and off from Home Assistant, I’m set! :grin:

1 Like

Ha thanks. :slight_smile: When I click on the entity on the device info page the entity info card only showed a binary choice for the fan:


My custom fan entity, on the other hand, actually shows a multi-speed option:

This is just the default entity info modal in Home Assistant and not a specific card, so I think Home Assistant just isn’t recognizing it as a three-speed fan. I did a quick search and didn’t see any way to change it, but I’ll try to look more closely this weekend.


What would the technical reason for this be? In on/off mode, is it not just a relay?

I think it just puts out 100% (like max speed) without any adjustments.

@EricM_Inovelli same issue as @Sky320 . I’m able to pair the device to my hubitat c8(blinks green), control it for a few seconds, then it blinks red and returns to pairing mode. I’ve tried the suggestions as well.

No. Its a Triac.

That is correct, assuming a neutral wire is connected. In non-neutral, its less than 100% but still non-adjustable

@jw.clark I was beginning to think it was me. Is there anything you tried that I don’t have listed/tried in any of my posts?

1 Like

The LED colors on the Fan switch are significantly different than the Blue light switches, especially when set to White which is my preference.

It may a different diffuser on the switch. I can see individual LEDs through the diffuser on the Fan switch and I can’t on the Light switch. Hopefully there is a firmware update that can adjust the colors to be closer to the Fan switch because a big part of the reason for going with matched switches from the same manufacturer is so they MATCH.

1 Like