2nd Gen Switch with HomeAssistant - Shows as, "Inovelli Unknown" and not, "Switch"


I finally managed to install the 2nd gen switches in my living room. The physical buttons work. I tested it.
I then managed to include the switches to my zwave network. It shows as “Inovelli Unknown: type=0002, id=0001”

I guess this is because the homeassistant openzwave version that we have does not have the latest manufacture setting file. Based on my research in homeassitant community, it can show as “unknown”, but it should still be fully functional. Is that true?

I tried to turn off and turn on the light from home assistant and i cant seem to get it working.
My zwave switches shows up as “switch” in home assistant. So its easy to call “switch.turn_on” service. But since this switch does not show up as a switch, i am not sure how to turn it off/on via homeassistant.

Hey @praveen12bnitt - thanks for taking the time out to post! Let’s see if we can get you squared away.

So I personally don’t have HA so I can’t really help, but I saw this post by @platup that may help:

I know it doesn’t specifically answer your question but maybe @platup or @EricM_Inovelli could help here.

Thanks Eric. Yes i saw the post earlier. @platup is trying to configure scenes and is in advanced stage. I am at a basic level. :slight_smile: I am assuming that he must have got all the basic on/off functionality working already. His feedback will definitely help me move forward.

I will provide all the info i have.

  • I am running the latest version of HA as a docker container on a Ubuntu laptop.
  • I am using the aeotec zwave stick.

This is how the red series inovelli switch shows up in my HA

In HA’s dev tools, i see 3 entities registered.

Let me know if you need any additional information.

Given the sensors were created, it looks like it was paired correctly.
You don’t have a “switch.inovelli_unknown_type_0002_id_0001”?

The other thing you could try is unpair the switch and try to update the open-zwave config and then rediscover it.
To do this, you’ll need to pull the “config” folder and all it’s contents from here: https://github.com/OpenZWave/open-zwave
In your “config” directory in hass, create a new folder called zwave, and then place the “config” folder you just downloaded in there.
The last thing will be to add the config_path to your zwave section in your config.yaml. It should look something like:

usb_path: /dev/ttyUSB0
config_path: /config/zwave/config

Reboot HASS and then try to re-pair the switch. Hope that helps.


Funny enough, I have the switch entity in HA, but not the sensors! The switch works. What are the sensors for?

I think I’ll try this and see what happens. I see @EricM_Inovelli pushed the config a few days ago: https://github.com/OpenZWave/open-zwave/blob/master/config/inovelli/lzw30-sn.xml

1 Like

The sensors are for power monitoring.
It’s actually pretty cool, I’ve always wondered what my Philips Hues were consuming when they’re “off”… and now I know :slight_smile:

I’ve also setup Circadian Lighting so it’s pretty neat to compare the power graph with the time of day, and somewhat surprising how much energy is saved just by dimming the lights or switching the color temp.

This worked for me. After following the instructions, I am now able to control my inovelli switched via HA. Thanks for your help. I am now going to get the scenes working. Let’s see how it goes…

1 Like

Did you do anything special to get the sensors to appear in HA? I’ve wiped my HA installation, reset my Aeotec Z-Stick and the LZW30, then re-did the setup, but I still only get the switch entity. No sensors. It is reading the config I pulled from github; I can tell that because it’s populating the device name and config property names.

Hey @wsdavis - do you have the LZW30 (Black Series) or the LZW30-SN (Red Series)?

The base model (LZW30) does not have energy monitoring built in, so that may explain why you’re not seeing the sensors.

Just wanted to throw that out there!

Thanks @Eric_Inovelli. You might be right. Sent you a direct message to look into my order; I might have received the wrong item.

Turns out I did receive the Black Series after all. Kudos to @Eric_Inovelli for figuring that one out and getting me set up with the correct model. Thanks!

1 Like

No prob @wsdavis - happy to help!

Just to close the loop here, I got the Red Series and it works perfectly.

Fantastic – great to hear!

@praveen12bnitt which instructions did you follow to get the LZW31 to correctly integrate into HA?

I followed the instructions and put the config folder from InovelliUSA/OpenZWave and added the config_path below. Now my Z-Wave USB can’t be found.

# Aeotec Z-Stick Gen5 USB
  usb_path: /dev/ttyACM0
  config_path: /config/OpenZWave/config/

@datzent83 This process works. If you have another USB port in use, the correct path may be different. You may have to look up which device is attached to which port.

If you only have the USB stick in, my guess is you are missing the complete or correct OZW config files, and that’s why it isn’t seeing the USB stick.

@platup off late I am having a strange issue. If I toggle the switch from HA , it works. However if I physically click on the switch the light turns off and on, however the status does not update in HA. If I tail the zwave logs, I see no updates. So I am guessing the switch did not send any updates to the zwave USB controller. Are u having the same issue ?

@Eric_Inovelli @EricM_Inovelli