3 way lzw31 + dumb switch not working as expected

We are replacing a single dumb switch in a 3 way setup with an red series dimmer. The neutral wire exists.

Our first Inovelli switch. Love the concept, but it is not functioning as expected.

The answer to my issue is to change configuration #22 to “1” – “3 way toggle.” However, I did that and it does not change the behaviour.

Wiring: Line into one box, traveler to 2nd box; load out of second box (in all this, I’m ignoring the ground. Ground wires are connected to each other and to green screws on switches, as applicable)

Box 1:

  • red series dimmer
  • 3 cables:
    1. presumably line in – black and white wired to the lzw31
    2. presumably the rest of the circuit: black and white wire nut to line #1
    3. traveler to other switch; white wire nut to the other two white in the box, black to load, red to traveler

Box 2:

  • dumb switch
  • 2 cables
    1. traveler: black and red to the two brass screws on switch; white wire nut to the other cable’s white
    2. black to black screw on switch, labeled “common”; white wire nut to the other cable’s white

The power on the lzw31 is always on, regardless of the position of the dumb switch. The lzw31 connects and behaves as expected to the hub (home assistant).

Configuration 21: “1” (neutral)
Configuration 22: “1” (3 way toggle)

Problem: with the dumb switch in position A, the lzw31 performs as expected; lights perform as expected. With the dumb switch in position B, the lights go off. The lzw31 still shows the dimmer bar increasing or decreasing, but the lights stay off. If the lzw31 shows “on” when dumb switch goes from B to A, lights turn on; if lzw31 shows “off” when dumb switch goes from B to A, lights stay off.

From everything I’ve read, the problem should be solved by changing Configuration 22 from 0 to 1, which I’ve done through the hub. The behaviour has not changed.

I’m sure I’m doing something simple, but can’t figure it out.

One other quick note is that I attempted, and believe I did–change the configuration directly on the switch (hold down config until yellow, then 13 taps – 1 long yellow, 3 short yellows: press up bar, 1 purple blink: hold down config until yellow then release: get two cyan blinks). However, when I then connected the switch to the hub, configuration 22 was still showing “0” - single pole, not “1.” Perhaps this is where I’ve gone wrong?

Can you set the parameters from the hub?

What @harjms said.

But if you want to try at the switch again, try it pressing up TWICE instead of once. I don’t know if this is the case, but since the parameter starts at 0, twice might get it to “1”. This is just a WAG, but I’m thinking that one tap sets it to 0, two taps to 1, etc.

Yes – I could have made that more clear. From the hub, I can read all of the node configuration items and set them. According to the hub, 21 is “1” = “neutral” and 22 is “1” = “3 way toggle” I’ve killed power to the switch, rebooted the hub, etc to confirm that the configuration is working. I’ve changed other configurations as well, such as ramp speed, etc. and those are working as expected.

1 Like

Can you confirm your wiring looks like this?

Also when the dumb switch is in position B, do you hear the internal relay of the red series click?

Yes this is the wiring. To ensure, I put the old dumb switch back and the two dumb switches work together like they should.
I’ve now put the lzw31 back in place and the behaviour is the same.
In answer to your question:

  • When the dumb switch is in position A OR in position B, the red series clicks when paddling up or down from on to off or off to on. The switch seems to behave exactly the same from all visual and audible cues. However, the lights only go off when the dumb switch is in position A.
  • If you were asking whether the red series’ relay clicks when–at the time of–the dumb switch going from A to B or B to A, the answer is no. I rather think it should.

Not that I want to sell you a switch, but I would HIGHLY recommend using an AUX switch. I’m not sure why your setup isn’t working. I know many people have the dumb switch installed with the dimmers without issue. I like the AUX switch because it allows control of dim level.

You are correct that the relay should click when you toggle the dumb switch. I’ll do some testing tonight to confirm and report back.

I agree with @harjms though, long term I will be installing Aux switches. I just got a tablet and ActionTiles license so my smarthome budget is a bit low right now.


Here is what I found to be the solution–and a couple of guesses at the problem.

I did not change the wiring. That was correct from the beginning of this process. Here’s what I did do:

  • Removed the lzw31 from the hub.
  • Did a full factory reset on the lzw31 (hold config down for 30 seconds (until red).
  • On the switch, set config 21 (which is 12 on the switch–see instructions) to 1. The default is supposed to be 1, and I don’t think I HAD to do it, but I did it anyway because this is the only thing I had not done in my original efforts. Whether this was a factor or whether I did something different in the original effort that I do not now remember is unknown. The procedure here is to hold down config 10 seconds until yellow, then 12 taps; the LED should show 1 long yellow, 2 short yellows: press up bar and get 1 purple blink: then hold down config until yellow again (10 seconds) and then release: get two cyan blinks.
  • On the switch, set config 22 (which is 13 on the switch–see instructions) to 1 (act with dumb switch–look for 3-way toggle). The default is supposed to be 0 (act as a single-pole switch). The procedure is the same as above for config 21.

This worked.

As a next step, I added the node to the zwave hub. No problem.

Here’s the interesting bit: The hub shows that configuration 21 is set to 1, which is fine, but it shows that configuration 22 is set to 0. And I know that the switch thinks that it is set for 3-way toggle (configuration 22 set to 1).

When I originally did this – first install – I set configuration 22 (on the switch, 13 clicks of the config button) to 1. It didn’t work as expected with the dumb switch. I then connected it to the hub and saw that config 22 was set to 0. I set it to 1 on the hub, not by going through the 13 clicks on the switch. When checking the node configuration, the hub showed that it was set to 1, so this is why I was thoroughly convinced that it was.

However, I don’t think that the hub is correctly reading or writing the switch information for at least config 22, maybe config 21 as well. I would note that the hub can definitely change the other configurations – ramp speed, dimming speed, LED behaviour, etc.; thus I think it has something to do with these special wiring configuration points.

I am using Home Assistant and an, for the zwave hub, “AEON Labs ZW090 Z-Stick Gen5”

The morale of this is that it looks like there may be a zwave communication issue with Home Assistant, the AEON usb stick and, at least, the Gen 2 red series dimmer.

1 Like