3 way With neutral issues. Please help, I'm at my mother in laws house now

I wired my 3 way, with neutral, based on the wiring diagram https://desk.zoho.com/DocsDisplay?zgId=691830694&mode=inline&blockId=k4wwh437a820318ff497da86f135e3829acb6
I am using the enbrighten aux addon switch.

When I have the setting SWITCH TYPE as LOAD ONLY, the controls for the main switch are fine. When I change it to 3 WAY MOMENTARY, it gets weird. If I turn it off, it immediately turns back on to a specific percent (not same as before). If I repeat the process, it goes back to the same percent value +1 (before it came back on at 69, now it is 70.). If I try to dim it below a certain value, it jumps back up also. At the aux, if I try to dim lower than the 70% ish, it doesn’t work, only higher. Please help! I don’t think my wiring is that wrong if it works fine with the load only setting and my aux can control as well certain functions. I tried on two switches with the same behavior.

Hub? Firmware? Load?

Bry, thank you:
This is LZW31
Controller Version 2.1.21-3 (Am I getting the right information?) How do I check firmware?
What do you mean by load? How many watts? I don’t know off hand. However, the lights work perfect using ‘load only’ preference.

You get the firmware version from the IDE. Open up the device page and post the value after the “ver”.

The load is what type of bulbs? Bulbs, screwed into cans, one-piece cans, etc? Incandescent, LED, CFL? How many and wattage.

If you want to post pics of the wiring we can check it. With the switches pulled out so you can see all of the conductors in the box and the conductors entering the box clearly.

I see it. It is firmware 1.35.

The load is a chandelier. I would need to get details from my mother-in-law.

I’m no longer in the house to open it back up. The wiring is very old, so it is a little hard to understand.
Previously I needed a little help on doing my first dimmer 3 way, in the same gang box (3 way, no neutral, possible bulb issues, unresponsive switch!). Now I am doing the left dimmer switch in the same box. As you can see, it is a mess and took me some time to clarify the setup. My testing indicated that for this 3-way setup, line was coming up to the first floor with a bundle of wires going up to the second floor switch. In that gang box there was another bundle for the fixture wiring. This is why I wired it per: https://desk.zoho.com/DocsDisplay?zgId=691830694&mode=inline&blockId=k4wwh437a820318ff497da86f135e3829acb6

My big question: I would think if it was wired incorrectly it would be pretty obvious. The fact that it works fine under ‘Load Only’ and not ‘3 Way Momentary’ is puzzling…especially the behavior I indicated. I was wondering if anyone has shown a similar behavior. I tested this with 2 different dimmers (both bought at the same time) and 2 different AUX switches - both bought at different times.

So at least according to the diagram you posted, the Line (i.e. power coming in) is in one box and the Load (i.e. the switched hot to the light) is in the other. The way it’s wired with the Inovelli and according the diagram, the load is really connected directly to the Load terminal of the Inovelli, albeit via the other box. So when you set the switch to Load Only, that’s really a 2-way switch configuration, which forgetting about the Aux, this is.

So since it works with Load only, at least that part of the wiring seems to be correct. That leaves a couple possibilities.

1 - Aux wiring incorrect - In the Inovelli box, there is a 3-wire or 3 conductors going to the Aux. One of them, the black, is passing the Load terminal to the other box. That seems to be ok. But make sure one conductor (white) is connected to the NEUTRAL bundle and the other (red) connected to the Traveler terminal on the Inovelli.

In the Aux box - white to the Neutral terminal of the Aux and red to the Traveler terminal

2 - Settings are incorrect - The 3-way momentary setting you tried is correct, but I have the feeling that sometimes the settings indicated aren’t really set at the switch. So play with the settings, setting them incorrectly and then putting them back. Try setting them at the switch opposed to the app. Try setting them incorrectly as well, including the non-neutral setting.

A couple shots in the dark -

If the chandelier has LEDs, temporarily swap out for incandescent.

Set the max brightness to 80%.

So this is the chandelier - Quoizel Bordeaux 4 Light 12" Wide Xenon Flush | Build.com

The neutral by the Aux should be fine. The traveler is the ‘other’ that should also be fine. The behavior is that I can control from the AUX, but with the same weird behavior from the main switch. I can only dim higher than 70ish. If I try to turn off, it turns back on. If I hold down it does drop to a dim of 1%, however, I can’t dim above that. I need to go to the app and manually set it back to 70%. From there, again, I can dim higher, etc. It is so weird! If the wiring was wrong, none of this should work :frowning:

This is the AUX switch (which works fine in my other dimmer (with a slightly different setup)

Preferences on IDE:

I feel like I always press config button the wrong number of times. I prefer to edit it via the app.
Would debugging and looking at the IDE somehow let us know why the weird behavior?

Are those the current settings? Look at parameter 21 and 22.

21 is the power type. It is properly set to “1”, Neutral.

22 is the switch type. Right now it’s set to 0, which is incorrect. 0 is for a 2-way switch. It should be set to “2”, multi-switch Aux.


I believe in the app it is called it is called load only, 3 way toggle, and 3 way momentary. I specifically changed it to load only so that it at least works for the time being. When we figure out what is wrong or do some testing, we can change it back.
Is there a way to view logs to see why it is behaving like this?

3-way momentary = Parameter 22 set to 2 = Multi-switch Aux.

Not that I’m aware of re the logs.

After you make parameter changes in the app, verify in the IDE. Or even try making the changes in the IDE.

I’ll try again tomorrow. Thank you. Since this seems to be a software issue, maybe the person who wrote the firmware would be able to figure out what is happening, just based on the weird behavior.