3x Sengled BR30 Bulb + Black Dimmer Switch - power cuts immediately


I am running into issues. I got 3x Sengled Smart LED Multicolor BR30 Bulb in my living room and I tried installing the Black Dimmer Switch. It works up to 55% “Maximum Dim Level”. Everything higher and the lights will cut immediately and the status led cycles blue green red. This would be fine but a) I’d like to use the leds at more than 55% and b) I run into my real issue when trying to run Smart Bulb Mode. I connected the switch to the smart lights in Home Assistant but when I try to trigger the HA Automation it goes straight to quick light flash → status led green red blue. My best guess is that the switch doesn’t respsect the 55% in SBM.

The building is pretty old. I do not have a neutral wire. Might a bridge or the Red Dimmer Switch fix my problem?

Any other suggestions?


Can you try using an incandescent to verify it isn’t cutting power while dimming the bulb? You’re using SBM, right? Which firmware? Are the bulbs wifi, zigbee, zwave?

So when you see the red, green, blue, the switch is rebooting.

If I understand correctly, you have the switch in the Smart Bulb Mode, which will insure that the bulb is fully powered, which you want.

It’s not clear to me what HA automation you are trying to trigger. It sounds like you are setting the illumination level. Make sure that you are addressing the bulbs and not the switch. You shouldn’t be telling the switch to go to 55%, you should be telling the bulbs to go to 55%.

Even without HA. If I don’t have it in SBM anything higher than 55% is unstable. Will eventually end in a reset :frowning: I can see what other non smart bulbs were in before and try with those.

EDIT: to be clear higher than 55% on the switch. Maybe if we can get that “fixed” or figured out the other part would also just work ( think).

Thanks for the quick help :slight_smile:

Can you post a link to the bulbs?

For sure. Sorry here you go:
Sengled Smart LED Multicolor BR30 Bulb

Model E12-N1E
Bulb Type BR30
Socket Type E26
Lifetime 25000 hrs
Warranty 3 Years

Brightness 940 lumens @2700k
Color Temperature 2000 - 6500k
Dimming Dimmable with app
Cri 90
Beam Angle 120º

Input 110-130V
Wattage 10.5W
Power Factor >0.7

Operating Temperature -4 to 104ºF (-20 to 40ºC)
Operating Humidity 0-95%

Those are zigbee. You’ll need to use scenes and SBM. What’s the firmware version on the switch? Can you post your config options?

A bypass might fix it. You can install it in the dimmer box if it’ll fit.

1 Like

He doesn’t have a neutral in the switch box so the bypass will need to go in the fixture

1 Like

Opps, yes needs to connect across the light fixtures however that can be accomplished. Regardless, the bypass is pretty much a necessity.


In case you didn’t know, when people say bypass they mean this…

1 Like

Yes, I am aware. I wish I wouldn’t have posted that I want to use them in Smart Bulb Mode.

Maybe to circle back. In normal mode.
I have them working (turn off / on). Using the switch.

BUT if I go above 55% dim level they will shut off (red, green blue on switch). With the limited knowledge I have on electronics. My first suspicion is that the lamps draw TOO MUCH power to handle for the switch (since they operate well from 0 → 55% dim level but die on higer levels).

If I understand you correctly. For the switch to be able to handle those higher loads I will need the Bypass you linked. Just want to make sure that that’s the function of a Bypass (handling higher loads). By reading the description of the bypass it doesn’t seem to help in those cases. My problem arises at higher dim levels not at low level. I am happy to try though if you expect this to make a difference. You seem to have more knowledge on this topic. Just want to make sure we’re on the same page here.

Thanks for all your help here already :slight_smile:

Edit: I’ll be gone for a few weeks but happy to record a video to show what’s going on. Basically the video will show me turning up dim level and eventually ~60% dim level the switch resets (red, blue, green).

That’s the only proper way to use them.

The Black dimmer will handle anywhere from 200 - 300W depending on how many heat sink tabs you removed, so it’s perfectly capable of handling the load of three of your bulbs. So the bypass doesn’t help handle a larger load, it helps power the switch properly in non-neutral configurations.

In a non-neutral configuration, the switch doesn’t always get the proper power to function properly. The bypass helps provide that power. Your switch is rebooting, so it is possible that is isn’t presently being powered properly, hence the bypass recommendation.

I am still thinking that you think you can dim the bulbs by varying the output from the dimmer. That is not the case. The dimmer should always put out full power by turning on the Smart Bulb Mode. The only way you can properly dim the bulb is by a command from the hub to the BULBS.

Now in your case, the switch may be rebooting as you attempt to get it to full power. The bypass may solve that.


Thanks Bry!

I will try the bypass. I am with you SBM is the way. And yes I want to run the bulbs at 100% and then control them through other means. As in routing commands of phone / switch to the bulb. (not dimming on the switch)

I was just thinking of solving problem 1) first: How to power the bulbs at 100%. Once that is solved I think SBM “should just work”

Sounds like bypass is a promising solution to try. Like I said not home for 2-3 weeks but will try right when I am back home.

Thank you!

Oh, AC and electronics is usually so much more complex than simple bulb wattage. In a non-neutral setup the dimmer can only power itself when it is not passing power to the lights. The rest of the time the power supply has to store a charge to power itself. So, the more you turn the dimmer up the less time it has to power itself.

It’s likely the bulb internal power supply is storing a charge so during the dimmer off times the bulbs draw no current which means the dimmer power supply can’t power the dimmer.

The reason the bulbs are likely not drawing any current during the dimmer off time is that AC is a waveform with peaks and the dimmer 55% on likely means the AC reaches the peak while the dimmer is on. The problem is that the bulbs likely only draw current at the peak of the AC. So, the only bulb current occurs during the time the dimmer is on. None when the dimmer is off, so no way for it to power itself.

1 Like

I think your setup is not capable of doing what you want it to do.

This is something that a lot of individuals get confused about with smart dimmers. You actually want to send 100% power ALL THE TIME to the bulbs, so they can be on the mesh and communicating always. You will use home assistant to turn on/off the dimmer and bulbs via commands, but smart bulb mode 2 (Always On) is needed, which is only available on the red dimmer so far (but is coming to others I believe in the future).

Definitely do NOT turn off SBM and try to dim up the bulbs, as all sorts of wonkyness will occur.

For now, I think you are stuck having to get a red dimmer to be fully set, but you COULD potentially hard reset the switch, set SBM to “on” then disable local control and set up scenes to control the bulbs via your hub since z-wave can’t directly control zigbee.

Your LED bar will always be on at 100%, but you can also work around that by adding the LED bar brightness parameter to your scene controls, so off = off, 50% brightness is 50%, etc. This would fade the bar brightness in and out, but it would always show 100% level, if that makes sense.

You also would never want to switch the switch off via HA. Disabling z-wave control (remote protection) is an option, but not one that I typically see used and wouldn’t let you dim the brightness on the LED bar, so not recommended, you just need to ensure HA never commands the dimmer level.

Hopefully this all makes sense.

Also, @PJF I can’t tell whether you are talking about the bulbs or the dimmer, but the dimmer powers itself by bleeding current from the load whether on or off. Sometimes when the “off” load is too small the bleeding of power isn’t enough so that’s why the dimmer resets, and also why adding a bypass puts an artificial, permanent load on the dimmer so it always has enough current flowing to power the dimmer.

Happy Monday!

1 Like

Not exactly. I need more explanation. The dimmer works by only passing part of the AC waveform, so when “on” the dimmer is actually more or less constantly switching on and off 120 times a second. The dimmer can only power itself when it is off and not passing any power to the load.

Here is the dimmer at about 50%. It is only “on” and powering the load when the beige line has the peaks.

If you look closely right before the big pulse there is a little blip, that blip is the dimmer power supply charging itself. If the load is incapable of “leaking” any current at that time then the dimmer can’t power itself.

1 Like

Thanks for your input.

@PJF @kreene1987, do you also agree with the sentiment that the Bypass should/might fix my issue?

Yes, it should. I think I saw a post where someone had to use 2 bypasses to make it work, but still try one and see if it helps.

1 Like