Apparently defective Blue won't Pair Properly

I opened a ticket for this, as it appears to be a defective switch which wouldn’t be a community-fixable issue. However the response to my ticket was for me to go away and try here. So, here I am.

Contents of my ticket:

My original order included 4 “bad batch” switches. One of the replacements appears to be defective.

I installed it in a location where one of the original bad switches was. It paired, but only had a few sensor and configuration options. I did several factory resets, as well as attempting to refresh through HA. Most of the time, it didn’t even correctly identify the model or manufacturer, showing up as “unk_manufacturer unk_model.”

I swapped in another of the replacement switches, and it paired and functioned correctly.

I tried the switch in another location. This one is in the same room as my HA controller–about 6 or 7 feet away with direct line of sight. It’s so close, that even the original bad batch switch could connect. The replacement switch still could not pair properly in multiple attempts.

Just FYI, I do have one of the four replacement switches I haven’t unboxed and installed yet. I’ll put it where the “new bad” switch is. I just thought I’d leave the “new bad” switch in for now, in case you want to me to do anything to debug it.

Here’s an update from the few days since I opened a ticket with the above info.

HA did eventually identify the switch after a couple of days. However, it intermittently becomes unavailable in HA. It does generally have an OK connection to the hub, which, again, is directly in front of it about 6-7 feet away. However, it has a poor connection to every other Zigbee device, including the one Blue that’s inches away on the other side of the wall.

What coordinator are you using, what firmware on coordinator, firmware on switches, z2m or zha and what routers are on your network?

1 Like

I’m using the HUSBZB-1 Zigbee/Zwave controller. I’m using ZHA, and Home Assistant is fully up to date.

The switch firmware is 2.08. (If you were referring to the firmware of something else, let me know.)

The only Zigbee routers I have are the other Blue 2-1’s and one plug. I also have a few buttons and a door sensor on the network, but they aren’t routers.

What channel are you on for zigbee and have you scanned wifi channels for interference? Do you have your hubzb on a USB 2.0 extension cable?

1 Like

I’m on the default, channel 15.

I’m in a neighborhood where the houses are close, and the 2.4 GHz WIFI spectrum is crowded mess.

I have the controller on a 90 degree adapter, but not an extension cable. HA is running on an old laptop. FWIW, the other switches work, including ones in the same locations where I’ve tried this switch. A “bad batch” switch worked fine in the location where I currently have this replacement switch. (That “bad batch” switch wouldn’t work properly at more distant locations.)

It sounds like the device isn’t interviewing completely with some clusters missing and/or interference on your network.

Some things to try:

Factory reset the switch and try pairing a few times.

Use a wifi scanner to identify a less utilized channela nd switch your zha channel to decrease interference. Use 5ghz on your wifi devices if possible.

Add a 3-5ft USB 2 extension cable to your coordinator. This is generally recommended for all coordinators to reduce noise

Add some additional routers to your network

Upgrade your current coordinator. Zha likes ezsp or c2562. Sonoff or tubez are both good options.

1 Like

I appreciate the suggestions.

I have factory reset it multiple times in each location I’ve tried this switch, so probably a dozen or more times by now. (I think I’ve passed the limit of that old “definition of insanity” adage.) FWIW, I’ve also tried restarting HA to try to eliminate issues on that end.

My devices that can be on 5GHz are. Counting my neighbors, I’ve got around 15 2.4GHz hotspots spread more or less equally across all channels. I do have my hotspot, which is obviously the strongest, set to a non conflicting channel.

I’ve moved the switch again, as I didn’t want an unreliable switch in an important location. The current position where I have this switch installed has 5 devices that are routers within 6 feet. It’s positioned between a two and a three gang box, both full of Blues.

If it were a network-level issue, I’d expect it to affect other devices. I’ve now installed this switch in four locations. Three of those positions work fine with other Blues. In multiple cases, this switch was replacing a “bad batch” Blue, and the known “bad” switch worked better than this new replacement. It’s actually doing better in it’s current location, presumably because it’s so close to multiple routers. But if it HAS to be that close to routers in order to function reasonably, and every other switch works fine, then it seems to me there’s an issue with this specific switch.

What’s the year/month sticker on the front of the problematic replacement switch say?

And I wonder what its IEEE prefix is, too.

I’ve run into something similar with my 2 replacements. In my case both were manufactured in August (“2208”) but are outside the known bad batches of IEEE identifiers. Trying to piece together clues. (FYI mine won’t get past “Interview Started” in Home Assistant ZHA with the hub 1 foot from the switch. Yours doesn’t sound quite that bad!)

It’s 2211, IEEE 94:de:b8:ff:fe:31:4e:04

When I started running into trouble, I double checked the IEEE to be sure I didn’t do something stupid like mixing up the switches and reinstalling the old “bad batch” switch rather than the new one.

FWIW, two of my other replacement switches have the same IEEE prefix and work fine.

Odd. Mine with issues are both 2208 with these IEEE prefixes:

  • 94:de:b8:ff:fe:…
  • 04:0d:84:ff:fe:…

First one matches yours, except made in a different month.

I also had similar issues with “fixed” bad batches. 2 of my 10 replacements were in the bad batch IEEE range. I tried them both and had issues with them stating connected. I tried a third switch which was outside the impacted range and it paired instantly.

I also noticed that those specific ones had older firmware compared to others in the batch I received even though it was labelled 1122 on the top left.

I’ve reached out to support with all the details but they’ve gone silent right now. :frowning:

It took a couple of days for support to get back to me. Of course, when they did, they just said that they were busy and I should go away.

FWIW, my switch did suddenly seem to improve after I had it installed near the controller for a few days. I did have OTA firmware updates enabled in HA, so it’s possible the firmware was updated. I didn’t pay attention to what version it was on originally. I’m not aware of firmware updates that would impact this issue, but who knows?

I’ve since moved it to a less important location-- my utility/laundry room. The Zigbee network should be strong there, as there are numerous Blues in the general area. I haven’t noticed issues with staying connected, but, again, it’s in a less used place with very little automations controlling it.

First I want to say I apologize for the issues your seeing and we’ll get to the bottom of it. Either by figuring it out or by issuing another replacement that I will physically test myself.

As you can see there are a few factors at play and it’s hard to understand what it could be. I’ve tested a few of the, “bad” IEEE’s from the new batch and they’ve been working fine with SmartThings.

We can’t figure out if this is something to do with HA or what and have been working with a couple of the people who are having this issue.

Regarding your comment about us telling you to go away, I’ve read both of your tickets and nowhere in that thread did we tell you to go away.

Nate suggested you reach out to the community regarding this issue as it seems HA specific and if you didn’t hear back to please follow up. This was on January 13th and we haven’t heard back from you.

Now that’s not to say I agree with the stance that was taken to defer you immediately to the forum and I will talk with Nate about it and have him talk to Eric and I about the problem you faced, but 99% of the time something gets posted in the forum and is solved before we even get to the ticket so I’m sure that’s one of the reasons he suggested it.

As mentioned, we’re working on figuring out the HA issue and I believe the other Eric mentioned there’s a fix submitted on GitHub that should help some of the traffic issues which may be the root cause of these pairing issues.

I will have Nate reach back out.

5 Likes

It’s good to hear you’re investigating the issue.

I was being hyperbolic and reductive for the sake of humor in saying the response was for me to go away, but tone is difficult to interpret in written communication. It would have been more accurate to say I was told support was busy and it was suggested I try here instead.

I’ve worked in customer-facing customer support, so I’m sympathetic to the difficulties it entails. Tech support at a distance is difficult at best, and I’m sure you’re overwhelmed with requests from people who didn’t read the instructions, people who don’t know how their own hubs work, and the “It doesn’t work” type of request without enough detail to even guess at the problem. That’s why I was waiting to see if the community could help before escalating with support.

From what I can tell–which isn’t much given my sample size of switches–this doesn’t appear to be another “bad batch” as three of my replacement switches have the same IEEE prefix, but only one had issues.

1 Like