Association not working

I bought the Red Series plus 2 bulbs special pack, so i have a red series dimmer and the zwave bulbs. I have installed the Red series dimmer DTH in smart things, installed both smart apps (parent and child), set up the source device (the red series dimmer) and the destination device (the zwave bulb) with association for groups 2 and 4. And they both show zw: ls in the device description (so matching security protocol). But nothing works. The switch does not turn the bulb on or off. Nor does it follow the dimming level. Help?

Did you also set the “Disable Local Control” parameter to “Yes”?

No, hadn’t done that. When I do that, I get an error saying “child device creation failed. Make sure the device handler for “switch level child device” is installed…so looking up what that’s about…

Ok, so I installed the Switch Level Child Device DTH. Then I unchecked and re-checked the “Disable Local Control” parameter. I assume it did its thing. Then I undid and re-did the device associations, just in case that was needed. But it’s still not working at all…

I’ve attached how these are set-up in “My Devices” … you may want to compare yours with mine.

Mine looks similar to yours i think. Except maybe a different DTH for the dimmer because they are named differently? But the associations are there…

Looks like the DTH listed on the “Device Handlers” page is not the same as the DTH listed on the product page itself. I changed the DTH to the one listed on the product page, so it matches your setup. Still not working.

Why do you have an entry for “Association Group 3”?
At this point, I would “exclude” the dimmer switch then re-pair it and start from scratch.

The settings in the switch itself seemed to suggest group 3 was for dimming even though the online instructions suggested it was group 4. So I added both since I figured it couldn’t hurt. Anyway, after re-adding it still doesn’t work. Frustrating. Going to try with a Zooz switch to see if it is the switch or the bulb

You could also contact Inovelli Support directly:
I’ve found tham to be responsive and helpful.

Group 2 is Basic Set (on/off commands)
Group 3 is MultiLevel Set (on/off and dimming values)
Group 4 is MultiLevel Start/Stop (start dimming when button is held, stop dimming when button is released)

You need either group 2 or 3 associated in order to turn the light on and off. Group 4 is needed in order to control the dimming functions. I added all 3 groups, and haven’t had any issues. (I am not using ST though)

Some things I recommend trying if you haven’t already (at least to help pinpoint the issue):

  • Try associating the dimmer with another zwave light (or even to another switch) using association group 2. This could help pinpoint if it is an issue with the switch or with the bulb
  • Try associating a different switch to the bulb to see if that works.