Aux Switch Enbrighten 46199 not working with inovelli red series dimmer

I am using Inovelli red series dimmer with Enbrighten 46199. I use smartthings hub. I can see i have selected neutral and 3way momentary switch in parameters. Parameters 21/22 are 1 and 2 resp. The Aux switch does not respond. I bought two aux switches and both are not working along with Inovelli red series dimmer. Dimmer works standalone. Below is the wiring i am using.

This setup is controlling staircase lights with the dimmer upstairs and aux switch downstairs. Let me know how to debug this

Before installation, did you confirm using a meter which of the boxes has the line and which has the load, or did you just wing it?

1 - Pull the airgap to reboot the switch and re-try
2 - Change P22 so something other than 2. Confirm in the IDE that it changed. Then change it back to 2. Confirm in the IDE again. Re-try.
3 - Pull the switches and double check that the conductors are firmly connected. You should be able to give a good tug without them coming loose. For the Inovelli, ensure the conductor is BETWEEN the backing plate and the exterior face of the switch. Re-try while they’re hanging out of the box.
4 - If still nothing, take pics of the connections so we can see into the boxes with the conductors pulled out as far as possible. Post so we can take a look.

I removed all the wires and manually connected each one to figure out my wiring from builder. Load, line and neutral are in the box where the dimmer is there and the other box has travellers, neutral and line.

  1. Tried just now and did not help
  2. Tried just now and did not help
  3. After wiring i used multi meter to make sure connections are firm.
  4. Pic of the Aux switch wiring attached. The voltage between neutral+line and line+ground is 120. This confirms the intact neutral connection.

One more thing i noticed is the dimmer does not control the brightness of light instead just turns on and off. Also smart things report F/W version as 1.35
PS: i am using the same dimmer with dumbswitch and load only in mulitple places in my home without any issues.

When you are using a meter to test, you need to confirm by testing against the ground as well to confirm you know which is the hot and which is the neutral. While there are no absolutes when it comes to conductor color, the commonly accepted method is (with some exceptions) use the black for hot and white for neutral, particularly in a neutral wiring scenario.

Looking at your picture, you’ve identified the white conductor as the line and the black conductor as the neutral. I’m not saying your incorrect, but if I am correct, you’ve wired the hot to the Aux and it’s supposed to be the neutral. Individually test the black with the bare ground and the white with the bare ground to see which one is really hot. You’re not going to discern that from testing across the black and white.

That is an extremely old firmware, probably the production firmware when the dimmer was first released. There have been a number of fixes related to the Aux switch use since then, so I think it’s prudent to upgrade your firmware to the most recent. You’re probably going to want the additional features that have been added as well.

Yeah i am testing AC current here. I did test both lines with gnd and i said the same in my last post.(The voltage between neutral+line and line+ground is 120V) and line+gnd is 0V. My platform being smartthigns i dont have a direct way to upgrade fw. Probably i need to move it to HA and bring it back to ST or use a Z-wave stick as secondary Zwave controller to do that. is there any easy way in smarttthings to update F/W?

I’d put the firmware upgrade aside for now. I’m not convinced your wiring is correct. You also stated that “line” to ground was both 120V and 0V, so that is confusing to me.

Let’s not use the terms line and neutral as they may not be correct. In the box with the Aux and referring to the white and black conductors you labeled in the posted pic, measure between the disconnected white and the ground and then measure between the disconnected black and ground and post those measurements. You want to identify which of those two is the hot. Only one will be.

I did a typo in last post . my bad…

  1. Between Line (White) and Ground (Green)=120V AC
  2. Between Line (white) and Neutral (Black)=120V AC
  3. Between Neutral (Black) and Ground (Green) =0V
    This confirms White wire is hot.
    I know my builder screwed the color by doing a line as white and neutral as black. Even i found it odd just in this romex box. I have Zwave controller stick and i am updating the f/w as i type this. I will update the findings once done.

Updated the Firmware (Zwave and Holtek) using secondary controller methods. It did not help

Either that or swap in another dimmer to confirm your wiring is ok

Did reset and tried manual config. That did not help either. Let me uninstall everything and share some pics. i have installed multiple electrical stuff over time. Hope i have not missed something.

After the reset and manually setting parameter, Aux switch did not respond. I went ahead and added it back in smartthings and then updated parameters via smartthings app, It worked.
List of things i did

  1. Upgraded the firmware
  2. Reset and excluded from smartthings
  3. Manually set parameters
  4. Added back in smart things again.
  5. Set parameters in smartthings app
    On step 5 it worked. Not sure which step or combinations of steps helped
1 Like