Binding two Blue 2-1 switches together in ZHA

I just wanted to share with the community a bit of setup trouble I had and a possible solution in case it helps anyone. Feel free to chime in if you understand this stuff better than I do and have some insights.

Original Setup and Problems

I have a few places where I have two Blue 2-1 switches that I wanted to be set up with Zigbee binding to control a dumb load. Basically:

  • Load switch: actually controls the load
  • Remote switch: wired to line, but controls no load, it only sends Zigbee messages to the load switch to get the light on/off/dimmed

This is basically like the wiring from Multi-Way (3-Way) + Smart Switch x2 Diagrams.

I had the two bound to each other directly in ZHA, but I was experiencing issues where the Zigbee message seemed to fail to get delivered from the remote switch to the load switch. (In one case the switches are about 10 feet apart.) This happened when the switches weren’t used for a few hours. Continuing to press the paddle up and try to turn the light on would presumably get a new message delivered & the lights would turn on. After that they could be turned on and off quickly with no issues at all.

I tried a factory reset and having them rejoin the network and reconfiguring the bindings, but that didn’t make a difference.

Possible Solution

I’ve changed the setup and put both switches into a Zigbee group and bound both switches to the On/Off and Level Control endpoints of the group. So far I haven’t experienced any issues with this setup.

Minor Details

I’ve got 47 devices on my network and 32 of them are Blue 2-1 switches.

There are 3 pairs that I have currently setup like this. They’re all actually unique in some way: one is a multiway with 2 blues & 1 aux, another has 2 blues & 2 aux, and the last one is actually just two separate loads that I want turned on/off at the same time.

1 Like

I’ve had similar issues. Every time I have had two or three switches bound directly together I’ve encountered inconsistent issues where something seems to go wrong with the signal and one of the other switches doesn’t respond.

I never encounter these issues when I switch them all into a zigbee group and bind to that. This is my preferred setup anyways, particularly when a smart bulb is also involved, for home assistant control. But, I don’t know why multiple blue 2-1 switches bound together never seems to work consistently.

I don’t have any actual aux switches, they are all blue switches even when acting like an aux.

I’m curious if there’s a bug in something. If so, where is it? The switch? The coordinator hardware? The protocol?

If so, how would go about tracking it down in order to report it?

It’s possible that it’s an issue with the zigbee network itself – sending a group command is likely much more efficient. Probably to figure out what’s going on really need to dig into the zigbee logs, but I’ve been happy using zigbee groups for everything, so I’ve just defaulted to that.

I generally need zigbee groups anyways if I want to properly control everything from Home Assistant/HomeKit (sending an on/off command from there you want to turn on/off both the switch and the light as the switch doesn’t poll the light for its state, so it’s best to use a zigbee group)

Yeah and if it’s a network issue, the HA logs may not catch it. I was looking into sniffing ZHA messages which seemed like it required an extra flash-able device and maybe also enabling MQTT. At this point, that seemed a little too much hassle since switching to a group fixed it.