Black Series Dimmer LED control?

Hello - I replaced a defective red series dimmer with a black series dimmer and it appears that the black series dimmer does not have start/stop notification capability in the custom action. Can someone confirm that? I was using the notification when a door was opened and if the black series does not have this capability, can the same thing be accomplished by setting LED colors and if so how?

Thanks for your help.

Red Series are the only ones that provide notifications as you described. I’m not sure if one could use a hub to configure a rule to change the child LED triggered by an event…I haven’t tried.

1 Like

There are custom actions in the driver to setComponentColor and setComponentLevel - I’m assuming that these refer to the LED? Do you know if these refer to the LED? I see the same things in the device driver configuration but I cannot put in the values there (it’s just a button) to check if this works.

Update: I just tried creating a rule to set the component color to 255 (RED - using the Inovelli toolbox) and I get an error in the logs

I think I have a rule that is working but it is not setting the LED to the right color.

The logs show this:

However, the LED color is WHITE. Any ideas why?

The LED goes back to BLUE when I lock the door and if the parent switch is on, it looks like it is 100% and if it is off, it seems to be 10%, so that part is working.

Do you have the latest firmware? The latest firmware allows 255 to WHITE; otherwise it defaults to RED with 255.

You should be able to adjust the LED child using the rule (if exposed). I would set LED color for the Generic RGB; note I haven’t tried to set colors this way via a rule on a Black Series. I have Red Series Dimmers for most of my notifications. But it looks possible.

Yes - I have the latest firmware 1.47 (both Target 0 and Target 1). I’m wondering if the issue is with the driver code for the child LED? The LED uses the default Hubitat driver.

The rule in RM sets the color to “Red” and “Level” to 100 (there is no option to choose a value, other than the colors in the drop down).


I also confirmed that if I change the color to “Green”, it works correctly (though I think the level doesn’t look right).

The other strange thing is that if I set the LED color to “Blue” in the device settings page (this uses the latest Inovelli driver). if I set the LED color via the RM (even though I’m using the color type (Red/Blue) that are in the Inovelli driver drop down), the settings on the driver page get wiped out and the color value is in the “Custom LED RGB value” parameter.

Does this look like something wrong in the interaction with the Hubitat Child driver and the Inovelli driver?

@EricM_Inovelli - could you possibly take a look at this? Could it be a driver issue or am I just “using it wrong”?

UPDATE: The reason (I think) that the level did not look right (above), could be because Parameter 15 is set to 10%. If the switch is “off”, then the LED does change color but it does not change level to 100% (it only writes to Parameter 14) until the switch is turned on.

Is there any documentation on the custom command componentSetColor? I’ve tried passing in the color as an integer but I get the error (shown in the first post) :frowning:

I’ve updated the driver to set the color to RGB when you use “Set Color” and change the color to White when you use “Set Color Temperature”. This should make it so that when you use “Red” in rule machine the LED changes to red instead of white with firmware 1.47+.

Edit: If you update an existing device to this driver you need to go in and change the child device driver to “Generic Component RGBW”.

1 Like

Thank you!!! This works… now if there was only a way to set Parameter15 through RM (or have it follow Parameter 14) since setLevel doesn’t seem to work if the switch is off (it follows Parameter 15)… :pray:t3: :pray:t3: :pray:t3:

1 Like

I think I will create a second child device for LED intensity when off. Might be a good idea to also have a custom command to set any config parameter though.

1 Like

That would be perfect!! Thank you - you guys are amazing.

It looks like I can address the LED intensity when on/off by using the rules directly on the current “child” device. Is that a no-no? Just want to make sure that I don’t mess anything. If I set the color to “red/100%” and then back to “blue/10% - if primary switch off” and “blue/100% - if primary switch on” appears to work (even though Param 14 is at 50 and Param 15 is at 30).

UPDATE: Umm - looks like when I muck with the LED level of the child device, I am actually overwriting Param 14 of the Inovelli switch. So while the “faux” notification works, the next time the switch is turned on, the LED level is incorrect. :frowning: I guess I could create a rule to set the LED levels when the main switch is turned on/off so that the LED level is correct - thoughts?

The child device right now adjusts the intensity when the switch is on so it does overwrite that parameter.

1 Like

I think I’ve been able to get around this by the following two rules:


Since I want my LED to be Red/100% - when garage door is open, Blue/50% if parent switch is on and blue/30% if parent switch is off, this would leave parameter 14 to an incorrect level (30%) when it should be 50%, which the rule below corrects.

@EricM_Inovelli - looks like the latest version of the drivers now have this capability!!! This is awesome…

Quick question - does setConfigParameter(number, value, size) follow the conventions outlined in the switch parameters?

So number would be Parameter as in Col 1 e.g: 1 (or is it 01?), value as in Col 5 (e.g, number between 0-101), size as in Column 7 (e.g. number 1 or 2). The device configuration page has some parameters (e.g parameter 14 and 15) that have percent in the drop down list, but the values in the config guide are listed as 0-10, so wanted to confirm.

1 Like

Yeah, you can go off of the config guide. All the options submitted with setConfigParameter should be integers (numbers in Rule Machine). Like to set parameter 1 to 1 it would be:

setConfigParameter(1, 1, 1).

Edit: Here is an example in Rule Machine. I made a rule to just turn off the LED notification. I did this to easily be able to tell if the process works. There are other ways to turn off notifications but this was just easier me to verify the command.

2 Likes