Black Series On/Off Switch (LZW30) freezing when attempting to update Firmware

I’m using the SiLabs PC Controller software and a UZB stick to update the firmware on my devices. I’ve successfully updated numerous Red and Black series dimmers but none of my switches (LZW30) will update. The only one I actually need to update is currently on the 1.11 firmware and I’m attempting to flash the 1.20 firmware onto it. When I hit the “update” button in the OTA utility on the PC controller it brings up the status message and just hangs there for 10-15 seconds before disappearing. There is no error message and once the message is gone the switch no longer responds to z-wave commands or physical presses. Pulling the air-gap and restarting the switch brings it back on the network and it works as expected. Any ideas on what I might be doing wrong?

Which version of PC Controller you using?

Are you using the PC Controller integrated with a hub? SmartThings, maybe? I’m guessing that based on the number of devices being displayed. A number of people here, myself included, have had flashes hang part way using the PC Controller integrated with ST.

I’d recommend you try the PC Controller as a standalone utility as opposed to a hub integration. You do have to remove the device from the hub and then re-add it, but I’ve never had a flash fail using this method.


I can give that a shot when I find some time to mess with it but it’s not hanging part way through, its just not starting at all.

Try 5.39

I’ve got one that does the exact same thing trying to upgrade with zwavejs2MQTT. I’ve tried it a bunch of times and looking at the network information it is 1 hop from the USB stick with lots of routes so it shouldn’t do it. I haven’t tried to move it or use a different method yet. I don’t know if the update is really worth that much effort for a simple on-off switch location in a closet.

Just tried 5.39 and it did the exact same thing.


Pull air gap on switch.
Start OTA upgrade on pc controller.
Push in air gap on switch. Watch it boot up and should almost immediately begin OTA upgrade. M
If all fails, May be best to exclude switch and just include it to the stick 1:1 for upgrade. It’s a pain but not sure what else to try.


I’ve also got one doing the exact same thing with zwavejs2MQTT. It’s also 1 hop from the USB stick with many routes. I have several other LZW30s directly connected to the USB stick and they all updated perfectly fine as did all of my red series dimmers and switches (which all have a max of 1 hop).

I did try as well with 5.39 of the PC controller and got the same behavior with that one switch. I have not tried moving the USB stick closer to that one switch. In case it’s useful, that switch is also currently on 1.11.

This actually worked! I had to get my wife to help since it was on the other side of the house and my UZB Stick is in my desktop, but it worked first try. Thanks for your help!


Trying to start upgrade then pushing in air gap did not work for me. I’m probably going to replace that switch with a dimmer so I’m not too worried about it but I’m using a laptop for the unRAID server there so I might try moving it close and upgrading again.

Wow. This worked. Thanks!