Blue 2-1: Can't change some settings via Z2M or HA

I’ve had two switches installed for just over a month now! These were a test run before I committed to buying them for my entire condo.

There’s a few settings I’m unable to change. Every time I try to disable the switch relay click sound, I’m presented with an error!


Similar behaviour happens with a myriad of settings, but not all of them.

As I make the changes to the switch, I’ve tried pushing buttons to “wake” the switch, and I’ve also tried cutting power from the breaker to it, restarting the switch, and trying again after a short time. Nothing will allow me to disable the click.

  • 2-1 Firmware: 2.14
  • HAOS version: latest (202304)
  • Zigbee Adapter: SkyConnect
  • Zigbee Software: Zigbee2MQTT

What’s your z2m version? I’m on 1.30.3.


Did you try the configure button? I don’t get that error.

What does that button do? I haven’t pushed that button at all. I’ve been pressing this button and assuming that would be enough for the setting to take effect. That works for the rest of them, and as soon as I push it, that’s when the error log is generated.

Anytime you do a firmware update you should reconfigure.

Is there a source on this? I’ve never heard this before

Did you see the link i shared? That’s the user guide for z2m.


Allows to manually trigger a re-configure of the device. Should only be used when the device is not working as expected (e.g. not reporting certain values), not all devices can be configured (only when the definition has a configure in its definitionopen in new window). Allowed payloads are {"id": "deviceID"} or deviceID where deviceID can be the ieee_address or friendly_name of the device. Example; request: {"id": "my_remote"} or my_remote, response: {"data":{"id": "my_remote"},"status":"ok"}

I did and looked through it and didn’t see anything specifically stating to reconfigure out firmware updates. It’s possible I missed it though?

You are correct it does not explicitly say to do it on a firmware upgrade, but it does say to run it when values are not reporting correctly. In this case they are not reported correctly because new parameters were added. To use the new ones the device needs to go reread the device definitions. Depending on the version of z2m you had when you installed the switch it may or may not have had the latest definition. The relay click functionality was added in a commit on 11/7/23. Although I do not know when that commit actually made it into a z2m release. Most recently the definition was updated to support the 2.14 firmware.

Relay Commit - Inovelli VZM31SN - fw 2.05 Support (#4910) · Koenkk/[email protected] · GitHub

Latest commit - Support additional features of Inovelli VZM31-SN 2.14 firmware (#5654) · Koenkk/[email protected] · GitHub