Blue 2-1 does not update state via Zigbee

My switch works as intended: I can toggle, turn on/off the light.

However, when I manually switch the light, this state is not updated via Zigbee. Only after I manually refresh the state in zigbee2mqtt.

I am using z2m with the Sonoff Zigbee 3.0 adapter.

I’m pretty sure this should update automatically, right?

Anyone having similar troubles?


are you talking about in the z2m device page? that page is buggy and values don’t show up automatically. if you look at the entity within home assistant, it should be working fine. if it’s not, then i agree there’s something wrong.

I do but unfortunately it doesn’t update on HA either.
That’s the whole reason I started to look at this z2m status page to remove an unknown.

What could I try to fix it?

1 Like

I don’t use z2m, but the status updates pretty much instantly (fraction of a second) in HA/ZHA for me.

1 Like

See similar issue here. Can be fixed manually by adding reporting bindings or just waiting for the next z2m version. Blue 2-1 Z2M not correctly reporting switch state in dimming mode - #3 by kdkavanagh

1 Like

I don’t use the dimmer but otherwise exactly same issue.
Wow nice, hopefully this is it!

Do you have a pointer on how to fix the bindings temporarily?

I followed your GitHub report but I’m not clear how.

1 Like

You’ll want to got to the device settings in z2m → reporting tab → add a new reporting entry to report onOff to the coordinator.

Admittedly I haven’t configured that reporting myself - just waiting for the next z2m update. In the meantime, I’m using an HA automation that would trigger on mqtt events using a wildcard, zigbee2mqtt/+/action, and then simply publish an mqtt message to force the coordinator to query/update the onOff state for the device triggering the action. (Got this working before I realized the reporting option wasn’t set up, so just sticking with this for now)

alias: System - Light Switch Action
description: ""
  - platform: mqtt
    topic: zigbee2mqtt/+/action
condition: []
  - service: mqtt.publish
      payload: "{\"state\":\"\"}"
      topic: "{{ trigger.topic | replace('action', 'get') }}"
mode: single

Decided to take your bugfix meanwhile. Works like a charm — thanks!!

One thing though: the dimming level does not sync. So if I change dim level via the paddle it is not reflected in HA.

Does this work for you? Or does it require an additional automation?

I havent tried it with any level information, sorry.

Worth noting that this automation hack wont work when the switch is toggled at a dumb-switch in a 3-way setup. For that, you need to add the proper reporting bindings

1 Like

Looks like to make it work for brightness, you’d need to change the mqtt payload from “state” to “brightness” per Inovelli VZM31-SN control via MQTT | Zigbee2MQTT