Blue 2-1 fan switch fails to factory reset

I installed a Blue 2-1 Fan Switch and paired it with a Hubitat C8. This worked fine. I was starting to migrate my devices to the C8 when the C8pro came out so I paused the migration and today I moved the devices from the C8 to the C8pro (only half a dozen at the moment).

When it came to the 2-1 I removed it from the C8 and nothing was discoverable on the pro. I looked up the factory reset sequence - hold config and up buttons for 20 seconds. Nothing happened. I held the buttons for shorter durations and upwards of a minute. Nothing. In the FAQ pages it has a video that shows the LEDs changing a couple of times before the reset. Mine never changed from blue. I tried the down button, triple tap on the config, etc. Never got a change. I also pulled the air gap a few times.

How can I get this reset and paired to the new hub?

By any chance is the switch in the Smart Bulb/Fan mode or is Local Control disabled? Certain switches (it varies by model) won’t factory reset if either of those are turned on. I don’t remember if that’s true for the fan switch, but it’s worth checking.

Yes, it is in smart bulb mode with the local control disabled.

Okay so turn that off and then you should be able to factory reset your switch.

Wow, that’s a pretty big oversight. I’ll have to look up the button presses to do that. If I recall it shouldn’t be more than 100 or so. :joy:

This information would be good to have factory reset FAQ. It would have saved days of frustration and sore fingers from holding down the buttons for extended periods. Of course, not failing the remove would have been better. :wink:

It isn’t responding to any button sequences.

Reboot it using the air gap?

Many times. I tied various combinations from the parameter list and didn’t get any indicators other than solid blue.

So I guess it got bricked by removing it from a hub.

If it’s not responsive by any means using the techniques above then I’d definitely recommend submitting a RMA.

I just submitted a support ticket. I can RMA from there if they wish. I can’t imagine just removing it from a hub would brick it. :man_shrugging:t2: