Blue 2-1 + Hubitat + Zigbee Group Messaging: Dimming?

Hey, all. I use Hubitat. I have a VZM31-SN (Blue 2-1) controlling a handful of bulbs. When they were dumb bulbs, I was able to set the switch to gently ramp up every time it was turned on/off at the wall.

I replaced the bulbs with Sengled Element smart bulbs. I followed the group binding instructions at How To’s | Setup Zigbee Group Binding - Hubitat , and they worked great! But there’s one problem: Now, when I turn on the switch at the wall, all the lights turn on suddenly. Nothing gentle about it. I know the bulbs are capable of slowly dimming, because the “start level change” command in Hubitat does it nicely.

Has anyone gotten this setup to work and not have the lights come on and off suddenly? (Even if you’ve done it with a different hub, that might be helpful, but Hubitat feedback would be most helpful.)


I have been looking at this a little and I believe it is an issue with the bulbs and how they are configured to respond to an on/off command. Most bulbs have a default behavior, and you can’t configure them to change. The switch has a setting to use on/off with level to turn the bulbs on, but I don’t know if that would make a difference. You can certainly test it out to see how it goes.

Thanks, Eric! This setting looks like what I want, but it doesn’t seem to actually change anything. With the setting either off or on, I get the same behavior: Using “set level” on the switch to change the level when the lights are already on results in a nice steady ramp. But using either “on” or “set level” when the lights are off results in a sudden change, and using either “off” or “set level: 0” when the lights are on also results in a sudden change.

I guess at that point, it seems the switch is doing what I want, but the bulbs aren’t doing what I want? If so, that’s a shame, but I thank you again for your help and for making Inovelli products so configurable. (The bulbs might have a useful configuration option, but I don’t have time to look into that as well right now. I’ll play more later.)

Hi all, I have a similar issue but with the Philips Hue bulbs.
I have a Hubitat controlling 3 Hue bulbs and 1 Blue dimmer (in smart bulb mode) bound together, following the same binding instructions as above. Toggling the switch On/Off does control the bulbs and works to turn the bulbs on and off. In my case, when turning the switch On, the Hue bulbs ramp from off to their brightness setting. Except, when turning the switch Off, the Hue bulbs turn off immediately (no ramp).

Strangely, if I control the Hubitat Device Group (3 bulbs + dimmer) directly, they behave as I would like. All bulbs ramp On and Off appropriately. This behaviour would indicate to me that they are capable of functioning the way i’d like, but I’m suspecting there is a Dimmer configuration i’m overlooking. Any help would be appreicate!

1 Like