Blue 2-1 & Philips Hue in Smart Bulb Mode - Switch Loses Power When "Off" Pressed

Hi all, I have a Blue 2-1 switch and Philips Hue light in Smart Bulb Mode that is exhibiting some strange behaviour. Basically, everything works properly (local and remote dimming, turn off), but once the switch is turned off (either locally or remotely), it kills power to the switch and won’t turn back on again.


  • Switch: One Blue 2-1 switch connected in a non-neutral setup and set in Smart Bulb Mode
  • Bulb: One Philips Hue 5/6" color and ambiance retrofit recessed downlight (model #9290031346)

The light fixture has a bypass installed.
I’m using Home Assistant with zigbee2mqtt installed in a docker container.
In Z2M, the switch is bound to a group containing the bulb and the switch, per this video. (Note: the section of the online manual for z2m binding is a copy-paste of the ZHA instructions and haven’t been updated since last May, so I’m kind of flying blind here on how to set this up).

I am able to dim and turn off the light using the switch (locally) and through Home Assistant/Z2M (remotely).
When I click “off” on the switch (locally) or thru HA/Z2M (remotely), the light dims and turns off as expected, but I am unable to turn the lights back on locally. I get a “publish set state failed” error in Z2M if I try to turn it on remotely. The LED indicator on the switch turns off completely and I read 0V on the load side of the switch w/ a multimeter.
If I pull the air gap and re-seat it, the switch will do its reset sequence (LED indicator flashes green, etc.) and then power on.
Oddly, if I turn on the light in Home Assistant (not the switch, but the Hue bulb itself), it will flash on, then off, then turn on and stay on. The light switch flashes the same sequence as when I pull the air gap and close it again. However, it shows as “off” in HA and the LED indicator is dimmed until I turn it “on” in HA or press the physical “up” button.

Things I’ve tried that have not worked:

  • Restarting Z2M and HA
  • Removing the switch from the Z2M group that is bound to the switch
  • Binding the switch to the bulb without using a group
  • Changing which clusters are selected on the “bind” tab - I messed around with including/removing the “OnOff” cluster but again, mostly flying blind as I haven’t been able to find much documentation for how this works.

Any and all insights appreciated! It may be that I need to give in and control the light through scenes but I would really love to get this working the “right” way, especially since it seems so close.

Yipes, sounds like SBM isn’t working properly if you are losing power. @EricM_Inovelli this sounds like an issue we need to flag with the engineer.

Edit: Nvm I didn’t catch non-neutral. Most likely a power draw issue!

Maybe there’s not enough power draw to use this in SBM? It’s a non neutral setup that has its requirements. Bypass is probably helping but not completely.

I have two other switches, currently with “dumb” bulbs, that I was hoping to upgrade to Hue bulbs - one circuit has multiple bulbs on it, and the other has a neutral wire.

I was waiting to get this one working before getting too far in the weeds on the other switches, but I can install hue bulbs on those circuits to test this theory this afternoon.

I would definitely say it’s worth the test. The little differences between neutral and non neutral will drive you nuts as it doesn’t always make sense (well at least in my mind).

I agree w/ @harjms . A properly wired non-neutral switch rebooting itself usually means insufficient power. Can you temporarily swap in an incandescent or cfl to see if it works properly with that bulb?

Also, which bypass are you using?

Edit: looks like a different issue

I had this issue in a neutral setup. The paddle was somehow moving the airgap piece. I had an extra (one of the “bad batch” blues), so I just sighed and put this one in storage.

I took the paddle off and pressed the buttons underneath and everything worked okay. If I held the down button with the paddle on it would stay off and reboot once I released. This was before changing any settings. Load-only with a neutral. Non-smart bulb mode.

I’m using the Aeotec bypass you offer.

Also sounds like @poptart911 might be onto something. Do you have another faceplate from a different switch you can try?

That sounds like the issue I sent you and Eric with the down paddle causing the switch to reboot. Removing the paddle and air gap switch, plus moving the micro switch helped cause after reassembly I wasn’t able to cause the switch to reboot with the paddle.

Update: I installed another hue light on my other switch in neutral set-up, and smart bulb mode is working perfectly on that. So I think it’s an issue with the non-neutral. I’ve previously had this 2-1 switch working just fine with a dumb LED bulb, so I don’t think the air gap problem would be causing this one.

Still a little confused on why there’s a power issue in smart bulb mode, though - isn’t the whole idea that it’s passing full power all the time?

Yes it passes voltage full time but current only flows when needed. So when it’s on, it’s pulling whichever wattage needed (say 16w), but when you turn it off, that current goes down pretty low and causes the switch to reboot. Maybe due to sudden drop of current from bulbs going from .13A to .01A for the smarts in the bulb. Plus whichever the bypass adds.

1 Like

That makes sense. Thanks everyone for your help! Looks like I will need to either find a way to pull a neutral to the box, or abandon smart bulb mode for the non-neutral switches. Bit of a challenge but at least I know what’s causing it now.

I know some people had luck with doubling up the bypass. Others would just rewire at the light to maintain constant hot for bulbs and send line/neutral to the switch for binding.