Blue 2-1 single down tap delay automation issue

I’m using a Blue 2-1 connected by ZHA to HomeAssistant to control 2 smart bulbs in a single fixture with the switch set to smart bulb mode.

I’ve got an automation with a single tap on the down paddle trigger that will turn the lights out after 30 seconds.

When I single tap the down paddle, the automation starts, but the lights immediately turn off. I can see the automation running (the 30 second delay processes), then the automation turns the lights off, but they’re already off.

I’m sure I’ve got something configured incorrectly in the switch settings. What do I need to do so that the switch doesn’t immediately turn the lights off, but allows the automation to turn them off later?

By default, single up and down control the attached load. You’ll have to enable local protection to stop the single down press from turning off the attached load and then your automation can handle turning it off after the delay. The same will be true for the single up press, you’ll need an automation to turn the load back on since you’ll have disabled that control at the switch. This also means if HA is down for any reason that light will not function without manually disabling protection mode.

Even in smart bulb mode?

Brain fart, I missed the SBM part. If binding is being used, I’m pretty sure local protection would still be needed. Otherwise SBM with no binding should be fine.

Can you point me to the docs on local protection so I can understand what that is and all the implications of that, please?
Also, what is “binding” since that seems to be different than SBM? Again, a pointer to the appropriate docs would be appreciated! I’m still learning my way around these switches and the documentation…

TBH, though, I don’t know that I’d want to enable that and remove the control of the bulb should HA ever be down (has rarely been an issue for me over the last 2 years or so).

Local Protection controls whether or not presses of the paddle will switch the wired load. So with local control enabled, the paddle will turn the wired load on and off. With local protection disabled, paddle presses will have no effect on the wired load.

These two terms have nothing to do with each other. Binding is used for Zigbee switches to get them to DIRECTLY communicate with each other. Although there are many uses, a common one is when two Inovelli switches are used in a 3-way (as opposed to using an Inovelli and an Aux). When you use two Blue 2-1s, for example, in a 3-way, they can’t be wired together in the same way you wire a Blue and an Aux. So you bind the two 2-1s together to get them to properly work as a 3-way.

You can look in for binding documentation for whichever hub you are using.

1 Like

Thanks for that, Bry. It’s been a bit busy, so I’m just now getting back to messing with this.

IIUC, turning off Local Protection should mean that a single up/down paddle press should do nothing unless I have an automation that responds to it.

I’ve disabled Local Protection on this switch:
image (Screenshot from HomeAssistant)
and have my automation set to delay 30 seconds before turning off the light. However, a single down-press turned the lights off immediately.

Obviously, I’m still missing something, please help a lost and confused soul… :slight_smile:

C7 running pretty good. They may have a BF sale coming up soon too.

You’ve got that backwards. Turning off Local Protection means that the switch does everything on the switch when the up / down is hit once. Turning on Local Protection will make it do nothing unless your automation responds to it.


What @rohan said. Turn local protection on, then trap the paddle presses.

I’m the last guy you want working on your HA automations, but there are plenty of HA users here that can help out.

Thank you very much!

This is, to me, completely unintuitive (obviously), but, now that I know how to make it work, I’ve got it.