Blue 2-1, Smarthings Hub, 2.15 Firmware Inclusion

Hi group,
Has anyone been successful at getting Blue 2-1 Zigbee switches included on a Smartthings hub that are already at firmware rev. 2.15.

I flashed mine while still on Homeassistant ZHA, unpaired a couple and am trying to get them paired on a Smartthings V3 Aeotec hub and can’t get it to successfully add the device. -Latest Inovelli Smartthings driver is installed.

Just looking for confirmation and/or troubleshooting to see if my firmware upgrade has gone past the current driver compatibility or something like that.


I should add:
-I’ve done factory resets.
-The switch acts like it starts to pair with the Smartthings Hub.
-Pulsing Blue turns to Green, then after 20-30 seconds I get a red flash on the switch then back to pulsing
-Not a signal / range issue, the Smartthings hub is 4’ from the switch.

-I can add the 2.15 switch back into Homeassistant just fine.
-I can even add a 2.08 blue switch to the Aeotec Smartthings hub just fine. But the 2.15 version firmware switch does not want to pair.

Hey @Dunlapjc - just wanted to pop in and confirm my entire house is on 2.15 with SmartThings so I think we’re good there. Let’s see what we can do to make this work.

One thing that may work is rebooting your SmartThings hub. Sounds simple, but I’ve seen that fix things before.

Another possibility is there’s some sort of weird outage with the platform. I can’t tell you how many times I’ve worked with someone and exhausted all the options only to found out ST was having some weird outage.

I know you mentioned you could add 2.08 but just curious if you’ve tried that at the same time as 2.15?

That did it. A full power cycle of the hub, physically removing the plug, and rebooting it did the trick! It still did the strange Smartthings quirk that I’ve seen with a few devices where it added the device, but didn’t show it until you backed out to the device list, but I’m used to that.

Thanks for the tip!