Blue 2 in 1, firmware 2.15 - multi tap stoped working

I had similar problems on HA latest + Z2M v1.33…The whole link between Z2M + HA broke, but just for inovelli devices. All other Z2M devices in HA worked fine + switches worked from Z2M itself, just not from HA.

Since it broke so many automations, I didnt bother to debug and instead rolled back Z2M to the prior version

For this (amongst other reasons), I have a blueprint for Scene Control for the blues that’s not dependent on the device triggers since it listens to the MQTT events instead:

It also has an added benefit of letting you listen to scenes from multiple switches and having them execute the same thing.

I have bigger issue right now - all my HUE zigbee devices (mostly motion detectors) have disconnected at night (and I am traveling now), and I have tons of automations based on them. Got a call from my wife (when she woke up and nothing was working). You can only guess the content of conversation

How I can roll up Z2M to the prior version remotely? need to do it NOW, or need to face the music


I start using your blueprint thank you for creating it
However, can you modify it for multiple triggers, I do not want to multiply automation that starts the same actions “go to bed” for every device I want to use as a trigger



I’m curious what automations you could have that are this critical to your wife? Sure, we create them because they make our lives more convenient and may feel a bit dependent on them, but if (when) your HA instance goes down for a few days, your house should still “work”, right?

It supports that already. You provide a list of entities and it makes them all do the same thing when triggered. This is a example of using it that way:


I run it via docker compose, so was as simple as explicitly tagging the version for the image and then recreating the container.

Bathroom lighting and ventilation for starter
Both light and fan were working all night
Upstairs bathroom next to leaving room triggers by Motion sensors
Outdoor lighting controlled with Hue plug
Garage lights use motion sensors

….and this is just a beginning
My house is fully automated….isn’t it the whole point of automation?


Maybe need some clarification
Sure you can start things manually , but if you counting on automation, you, for example, do not turn off light and fan in the bathroom, you do not turn off the lights in the back yard after sunrise
Granted, you can do everything manually but why automation is needed in first place?
I am considering my new build that will not to have manual switches at all
Learning how it is possible
Most likely I should avoid Zigbee and Zwave all together. Good for a hobby, but not for a causal user
Too much of a maintenance

Just a though

I made some more digging.
Zigbee networks works well, then one random command fails and the device is not connected anymore to the network.

I have a ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2 adaptor

A reboot of the Z2M add-on solves the issue until next failure.

BTW, Inovelli dimmers connecting back :slight_smile:

If you’ve got devices dropping off, then you’ve got some network issues there somewhere. I notice motion and outlets on there that seem to disappear for an hour or so. Which brands are they? Some brands like Aqara don’t always play well with others when signals are repeating and tend to drop off.

1 Like

All of my switches that were no longer responding to triggers in Z2M are now working again after pressing the reconfigure button in the device setting.

Yes they disappeared until I restarted add on
That was the point of publishing this chart
ALL Zigbee devices disconnected, Innoveli dimmers connected back, but all other did not until restart
Motion are Hue Philips, outlet I think GE, I have some Aqara sensors (light and temp-humidity)
Outlet plug is Hue Philips as well
BTW, in GitHub people are already complaining about issues after last update

Looking for some assistance with multi-tap.

When HA server is rebooted/restarted, the automation I create for Inovelli Blue break. The automation action trigger is now unknown as ‘up_double’, down_tripple’, etc are lost.

To get things going again, I must:

  1. Reset Z2m service
  2. go to each switch and manually double tap, tripple tap the switches so they are options again.

Not sure what (switch, Z2M, HA, or a combination) is the issue.

Thoughts or suggestions?


Nothing to do with Zigbee network. Any restart, reboot or such make all (except Inovelli) zigbee devices unavailable. Restart fixes that
In the Z2M forum main suspect is MQTT

I followed @rohan suggestion and used his blueprint
See post

Always design your smart home for failure, have manual overrides for any automated elements, etc.

I just updated all my switches to 2.15 as well and ran into the same problem. I tried the blueprint referenced earlier and that wasn’t working either. I started listening to the MQTT messages for the switch and realized that regardless of how many times I pressed the paddle, I was always getting a up_single or down_single action.

I checked the button delay and it appeared to be set to the default 500ms, but it was behaving as if it was set to 0, disabling the multitap. For the hell of it, I changed the value to 600ms and then back to 500ms and low and behold, the switch was working properly again sending up-double, down_double, etc.

I did notice also that when creating a manual automation, the only triggers available were those I had actually pressed, which someone else noted earlier.

I am also having this problem after upgrading to Z2M 1.33.1-1. My automations which were dependent on triggers like ‘down single’ or ‘up double’ now show ‘Unknown trigger’.

I’m going to have to revert to a previous version of Z2M without a solution.

Any thoughts, suggestions are appreciated.

You can use my blueprint referenced here: Blue 2 in 1, firmware 2.15 - multi tap stoped working - #23 by vladimir.korobov

It’s not dependent on those device actions working since it listens to the raw MQTT topics directly.