Blue canopy module stuck on Starting interview

Today I tried to install my first blue canopy module.
When I click on add device in Home Assistant (ZHA) it says “Device Found” almost immediately and starts the interview process:


But then it stays stuck on this until the LED in the module changes from flashing blue to steady red.
I already tried factoring reset the module (hold button down for 20 seconds) but it didn’t help.
Any time I start over (by pressing the button 3 times) I get the LED flashing blue but nothing changes.

Room is around 17’ x 20’ and has 3 Blue 2 in 1 Switches, two in one wall, one on another.
Fan is in the middle of the room and for now the canopy module is just hanging in there, wide open with direct line of site to these 3 switches.

Every room on this floor will have at least 2 Blue 2 in 1.
Assuming these act as repeaters, I 'm thinking signal strength should be a concern right?

Home Assistant Yellow (the hub), is in the first flow, coincidently right bellow this fan (room) so on a straight line going up (through the sub-floor) it should be about13 ft.

Home Assistant version 2024.6.0 and ZHA.
Hardware is Home Assistant Yellow and it’s built in ZigBee radio.
I have lots of Blue 2 in 1 combined with other ZigBee devices and everything else looks great.

I appreciate any help.

After trying everything I could, I did what was not too obvious to me since everything else was working as expected: I restarted Home Assistant. That did the trick :grimacing:

That’s a weird one. Glad to hear you got it sorted though.