Blue - need multi-tap setup instructions for Home Assistant ZHA

Team, the up_double, down_tripple, etc. multi-tap feature in HA is not working.

I was able to map the muli-tap actions in HA, but today, they all disappeared in HA. The HA automation’s I created now show unknown trigger instead of up_double, etc. The automation’s were working great for a bit over a week, now there is disconnect between the Inovelli Blue and HA. Has anyone seen this and have a work around?

I am also being bit by this. I finally get an automation in HA working with double tap and a few hours later it fails. Instead of “up_double” or “down_double” it says unknown. Very frustrating.

I guess I can switch from Z2M to ZHA and try the blueprint approach. Are people have more success with that?


I use a double tap down on a blue every day in z2m. I’m using NR versus the built in automations and subscribing to the mqtt topic

You can stick with Zigbee2mqtt and use this blueprint: Blue 2 in 1, firmware 2.15 - multi tap stoped working - #9 by rohan


Something quick to try.

  1. Restart Z2MQTT add on
  2. If you have created multi-tap switch automation’s before, they will show unknown.
  3. Now, go to a switch and physically press the double, triple, up down taps on the switch that the automation’s were previously created on.
  4. Go to your automation and the down_double, up_triple, will be shown and the automation will now execute moving forward.

Hi wardwolfram33,

Yes, I have tried that. Sometimes it works. Sometimes it doesn’t. For some reason, even when it works, it then stops after awhile. It could be that I am new to Home Assistant and so am messing with a lot of stuff, but it still annoying.

Hi stu1811,

I had not looked at Node Red yet. I just spent the last several hours figuring out how the pieces fit together and so far it is working beautifully!

Thanks you!


Hi rohan,

If I had seen your message before stu1811s I would have tried that. As it is, that looks very interesting and I will have to spend some time looking into it.


1 Like

Yes, every time I reboot the HA server, the multi-tap options disappear from their automatons. It is a pain! :slight_smile:

I have a light switch physically wired into my inovelli switch - I only want to physically turn it on if the light switch is double pressed - if it is single pressed - I would like to turn some lamps on instead.

Any tips?

Right now I just have it turn off the light on up button pressed once - but that causes the light to flicker and it looks kind of bad