Blue Series 2-1 Firmware Changelog | VZM31-SN

Based on some people’s results, it sounds like we really need an option to switch back and forth between trailing edge and leading edge. Is there a technical reason why this wasn’t set as a user-configurable parameter instead of basing it on wiring configuration?

2 Likes

That makes sense- I’m that case It’s entirely possible/likely these bulbs didn’t light at all at this dimming level with leading edge dimming. I’ll be able to tell better tonight when it’s dark if the lights seam any brighter at the new minimum level. I’ve got one switch still at 2.08 - it’s has two recessed lights vs 4 on the other switches but it might be a good reference point.

I believe it has to do with the way the relay is used for switch + dumb switch or non neutral. I can’t remember the details but thought it was a hardware limitation.

That might make sense for 3-way configuration, but for single pole installations, it was in leading edge before and trailing edge now, I can’t see how that couldn’t be a parameter (that is only possible for single-pole configurations.)

2 Likes

In a single pole configuration there is no reason you can’t tell the switch it’s in a 3-way and then select dumb switch or aux for your desired mode :wink:

5 Likes

I’m in the same boat, w.r.t the “pulsating” lights at low brightness levels - I wouldnt call it flickering, but getting slightly brighter/dimmer over the course of ~1s. This is with a single switch (so presumably trailing edge now), with 8 lights on the circuit. I increased the frequency of power reports from HA, you can see that it’s stable for a bit, then starts fluctuating, corresponding with the unexpected changes in brightness

2 Likes

That sounds exactly like what I was seeing. I’ve got energy reporting disabled so I don’t have graphs to check.

The good news is somehow I think it’s fixed for me now - unfortunately I’m not exactly sure what fixed it. It I had my minimum brightness set somewhere around 40 and it was still happening. I was planning on doing a factory reset tonight but before I did that I was testing all kinds of minimum brightness settings. Eventually I set the minimum brightness to zero and then increased the brightness in increments of 3 (basically 1%) to see how high I had to go for the lights to turn on at all. At 6 they were supper faint and at 6 they were on but flickered/pulsed. I might have been able to get away with 9 as the minimum brightness but I went with 12 just to be safe.

I’m not sure why I was seeing the issue at a higher minimum earlier and now a low value is working well. Maybe setting it to zero reset something or tiggered the switch to recalculate something but at least for now I’m quite happy with how it’s working.

I’ve got at least one other one circuit showing the same issue (different bulbs though). I’ll play with that one tomorrow and see if going back to zero on the min brightness fixes that one too.

So out of 60 switches. I only had 1 that went all weird after updating the firmware

Specifically, it kind of acted like it was in Smart Bulb mode (ie. always deliver continuous power), even though it WASN’T in smart bulb mode. I could not do any button combinations (ie. favorite + 3 or 4 paddle presses), or turn on/off the light (it was always on).

The switch itself responded to button presses (LED bar goes up, communicates with other switch, etc), if not favorite/paddle combinations - it’s just like the button was disconnected from the electric part that controlled the light.

Since I had that switch setup in a Master / Slave setup with another 2-1 switch, I have just swapped the master and slave switches (so now the one that WAS the slave, is controlling the light, and the one that WAS controlling the light only has power and communicates via. Zigbee). This has worked around the issue.

I probably could have RMA’d the switch that failed after it’s firmware was updated, but this way I don’t have to. It still serves it’s purpose fully, but just living on as a slave, instead of a load bearing switch.

I had a similar issue with flicker/fading. As well as some strangeness with ramprates that should have been 0, but were taking time to ramp on and off. Factory reseting the switch resolved the issues.

1 Like

I have a few switches that are causing the flashing bulbs as well. It seems to just be happening on my Cree recessed bulbs though. All of my Philips bulbs seem fine.

I did try the factory reset as well as changing the minimum dimming level to 0 and then back up with no luck yet. This was a little after sunrise so it was tough to see if they were still flashing or not.

1 Like

I am doing this. Still having some issues updating. A couple switches are still failing but I’ve got 6/26 updated. It seems I can only do 1-2 max.

2 Likes

AFIK that is true. But I can’t say 100% certain.

1 Like

I have 20 of these in the home (5 more in boxes still to install), running Z2M via HomeAssistant. 9 of the switches have updated to 2.14 no problem, but I have 11 that either have not, or are reporting 2.08 still (although they went through the upgrade process). I have been targeting them 1 at a time (yep… slow and steady). For those that have been upgraded but are still reporting incorrectly, am I forced to remove and re-add them to Home Assistant? It will be a huge pain for all my automations. I have tried reconfig etc, and they no longer respond to upgrade requests (I believe because they already are)
Any tips welcome!

Just for reference, I flashed 2 switches that both started on version 2.00 with no issues yesterday.

2 Likes

For what it’s worth, I had 33 connected units upgrade all at the same time through HA ZHA and the process went flawlessly. Some switches took longer than others, but they started around the same time and finished within about 10 minutes of one another. These were a mix of first batch fixed units and the second batch.

see my post above to update the information in z2m Blue Series 2-1 Firmware Changelog | VZM31-SN - #440 by bgreet

1 Like

So I ignored the switch for a few days and then it magically worked when I tried last night. ¯\(ツ)

For those of us with a ZHA HA setup, will the update process just happen at some random point in time on its own? Hard to tell from previous posts. Thanks.

It depends on your ZHA configuration. If you have ‘inovelli_provider: true’ in your configuration, I’d expect them to have already updated at this point. If you use the OTA directory to push it locally, I believe you need a restart to trigger checking for new files.

The Leading Edge/Trailing Edge issue caused an issue on my EMCOD ML100S24DC Transformer driving the my kitchen under cabinet LED strips. Using it as a single pole switch, the breaker on the transformer would consistently trip on the 120V side. Setting the switch to be a 3-way with a dumb switch stopped the issue with the breaker. The docs on the transformer require MLV (leading edge). May be worthwhile having a specific option for this.