Blue Series 2-1 Firmware Changelog | VZM31-SN

If you are using ZHA you can enable debug logging for zigpy

the OTA progress will show there and when complete it should show a sucessfull log entry.

I have seen the update abort, usually when multiple are running, but subsequent attempts have succeeded.

1 Like

That is due to saturated network / saturated COM on Zigbee adapter.

I’m using ZHA and included a log in a post here

someone else picked through and saw that it is reporting completed.

the switch is currently running 2.14

Sorry, I just saw that in your previous post. I’d turn logging on in ZHA and see if OTA is being deployed or if it’s being aborted before upgrade actually occurs. If it’s being aborted it is likely because:

1.) Switch is busy for whatever reason.
2.) Switch load is ON. Should be OFF.
3.) Someone pressed button on switch while in OTA deployment process. (This will trigger abort)
4.) Network is saturated and adapter triggered an abort / switch stopped responding - timeout reached.

Keep in mind that if you trigger multiple updates at the same time, you will lose routes to the switches after they’re in upgrade process and you’ll likely have an unstable network for a small time. If you only have switches doing routing and nothing else you should only trigger 1-2 updates at a time.

your best bet is probably the wire harness flash that @Eric_Inovelli is offering.

Not a bad idea, but figuring out the actual issue is probably a good idea too. It’s usually something no one saw coming lol.

1 Like

I’m not sure if that was directed at me, but I already have it on the way :smiley:

I was just throwing in my experience, that my dongle is fully up to date, has been sat right next to the switch, and still had the issue with only 1 of 5 switches. So, I don’t think it’s signal strength, or the firmware on my dongle in this particular instance.

If you did this already, please forgive me.

Try to:
1.) Pull tab out (kill power to switch) for 15 mins.
2.) Push back in.
3.) Trigger update with logging enabled.
4.) Don’t touch switch, keep switch turned off.
5.) Watch for 2 reboots of switch.

More importantly: Let us all know how far the switch got in the update process. Did it reboot once? Twice? This will be extremely helpful information.

I’ve gone through all of that and have a link to a fresh log.

The LED bar filled all the way to the top, but it did only reboot one time.

edit: I should probably mention that the switch is still reporting 2.14.

I dont think its an adapter firmware issue, and I dont think its a network congestion issue.

– I have over 20 switches, all of them have been updated at least once over the last year as the firmware was changed, during the switch from 14 to 15, all but 6 updated just fine on the first try. (not an issue with my sonnoff adapter). If it was network congestion, why would a switch on the other end of my house work but the one 10’ from the adapter fail. Why would one switch in the same gang succeed when another in the same location fails. If it I try the same switch 6+ times why would it fail every time when so many switches worked on the first try?

I am updating one switch at a time, and I tried updating a switch with no load. I tried updating at night when everyone was in bed so it had plenty of time without being touched.

I will gladly try the wired update, just trying to throw out some data so we can figure out what is causing it.

Strange, your log shows it trying to deploy 2.08, not 2.15. It has both downloaded though. Strange.

If it only rebooted once that means the update never actually happened.
It likely failed the checksum, deleted the file, and rebooted.
Or possibly, it’s not performing the update for some other reason.

@Eric_Inovelli Does the switch do any internal logging?
If yes, is there a way to view logs on the switch itself?
It seems the bootloader is giving a negative response when performing the OTA.
Possibly due to a checksum failure?

Not sure, more an @EricM_Inovelli question :wink:

That’s especially strange, because 2.08 does not exist in my ota directory. It also does not attempt to update at all when I remove the 2.15 file from said directory.

Not sure why but you can see it downloads 2.08 right before starting the update.

Oops, wrong Eric, lol.

@SamJWard using z2m trying to update from 2.11 to 2.15.
I setup a camera to record the whole update process. I exported from just before the update finished plus five min.
10 sec - OTA done and reboot
1:50 - LED flashes green like OTA is starting again
2:18 - Green flashes stop
2:22 - Switch reboot

It is currently 2 hours after the OTA process and the dev console is still reporting 2.11
Read result of 'genBasic': {"swBuildId":"2.11"}

EDIT: Where is the legacy attributes you mentioned?

1 Like

@stu1811 - need to borrow my Hubitat?

I’ve had this issue with ZHA. 3 of 30 switches refused to upgrade from 2.14 to 2.15.

@SamJWard logs from further up in the thread as well. You can see the OTA progress does show as complete, logs show a reply status of SUCCESS. It’s also reporting 16908815 which is the proper file version for 2.15. So I believe your hunch that it’s failing a checksum when the switch actually reboots to update itself may be correct.