Blue Series 2-1 Signal / Routing / Performance Issue Troubleshooting Thread

Yeah, channel use is all over, plenty of people using the default 15 as well. I have no issues with 25 currently fwiw.


May be helpful for those with working setups to post details of their setup.

Z2m/zha/hubitat/smart things
Coordinator and firmware version
Channel used
USB extension
Distance from coordinator
Lqi levels
Wifi environment
Home materials (drywall, brick, etc)

Anything else anyone can think of?


Wifi environment
Home materials (drywall, brick, etc)

1 Like

Anyone using an efr32 based coordinator with better luck instead of ti based chipset?

1 Like

Let me see if I can open up the results to the poll. Most of these questions are on it.

But I was also thinking about probing further to see if there are certain products that are similar in each setup.

So, stay tuned for a second poll. Hopefully I can get to it tonight, I’m tied up most of the day today.

Two days ago I installed two Blue switches in the same room. Both showed the green light, but I got this on my phone during the pairing process for one of them:

However, immediately after, both switches showed up in Z2M with LQI in the 60-80 range, and both showed online. I could control both, and they seemed to work fine, so I went on my way and forgot about the error message.

Twice now (in the last 48 hours), I’ve watched one of the two switches go “Offline,” even though it’s LQI has stayed in the ~60 range. When it first happened yesterday, I don’t recall doing anything, and it appeared back online about ~10 minutes later. Today, it happened again, but it’s been 20 minutes and it’s still showing offline.

Both are in the same room, and both have a similar view/distance to the closest router. Any thoughts?

Zigbee2MQTT: v1.28.0
Coordinator: Sonoff Zigbee 3.0 USB Dongle Plus, FW: v20211217
LQI: ~60


Thanks for posting that - super helpful. @nathanfiscus do these look familiar to you or have you seen this in Z2M?


I’ll dig up the patch, but the electrical measurement one has an update already merged into Z2M, can do it manually or wait for the update. That NWK_TABLE_FULL error is interesting though, possible to get the full output of the log? How many other devices in Z2M?

Edit, I think you found the thread, but - Power/Energy not available via zigbee2mqtt - #9 by tigers

I’d recommend updating your firmware. Somewhere in the last 6 months (July I think) the dev branch added an increased routing table size. Probably will take care of that 1st error.


I think what @epow is getting at is that Home Assistant is really just a very stripped down version of linux, so HA is not necessarily to blame but rather an application running on the HA environment. Semantics aside it helps narrow down where to look. Not sure about Z2M, but from what I understand ZHA is effectively just a translation layer controlling how Home Assistant interacts with zigpy.

If I have time today I will look through Zigpy issues on github and see if there are any known issues especially with the TI chipset as that seems to be the most common. It does strike me as odd that the github sonoff points to in their docs for firmware is still in the dev channel for the last 2 releases with the last stable release back in February. That said the conbee runs a different chipset, so it might be just a broader issue with zigpy in general.

Anyway I just want to reiterate that these switches are a hell of a product. I think most HA users expect and even invite a bit of tinkering, so rather than point my finger at the very obviously well engineered product I see this as just another issue to try and solve together as a community.


So this is what the Z2M addon run log shows:

And when I run debug inside the Z2M addon itself, and try to reconfigure the ‘offline’ switch, I see the following:

Debug 2022-10-29 13:56:02Received MQTT message on 'zigbee2mqtt/bridge/request/device/configure' with data '{"id":"Living Room Dimmer (Back)","transaction":"9xcy3-2"}'
Info 2022-10-29 13:56:02Configuring 'Living Room Dimmer (Back)'
Error 2022-10-29 13:56:12Failed to configure 'Living Room Dimmer (Back)', attempt 2 (Error: Bind 0x943469fffe089d93/1 seMetering from '0x00124b0024c16b95/1' failed (AREQ - ZDO - bindRsp after 10000ms) at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/src/utils/waitress.ts:64:35) at listOnTimeout (node:internal/timers:559:17) at processTimers (node:internal/timers:502:7))
Info 2022-10-29 13:56:12MQTT publish: topic 'zigbee2mqtt/bridge/response/device/configure', payload '{"data":{"id":"Living Room Dimmer (Back)"},"error":"Failed to configure (Bind 0x943469fffe089d93/1 seMetering from '0x00124b0024c16b95/1' failed (AREQ - ZDO - bindRsp after 10000ms))","status":"error","transaction":"9xcy3-2"}'

As for number of zigbee devices, I have 12 (including my routers/extenders):

1 Like

I just tried a Blue 2-1 with Smartthings. Installed in a bathroom ~20 ft from the hub, through 2 drywall walls - initial pairing failed. Moved the switch within a few feet of the hub - it paired properly. Moved the switch back to the bathroom, it responded occasionally (maybe 1 in 4 of the commands from the hub).
Plugged an Innr Zigbee Smart Plug into an outlet right next to the 2-1; it immediately started working perfectly!


For clarity, the Innr started working perfectly or the 2-1 started working perfectly once the Innr was next to it?

The 2-1 started working (the Innr was already paired & working properly, I just moved it)

1 Like

I haven’t seen the first error before. The second is an issue with the metering setup in the handler and is fixed in the master branch and will go out whenever z2m releases a new build. I think @epow is on the right track though. I just got a Sonoff coordinator and after doing some reading it sounds like the firmware upgrade is just about a must if you have a med-large network.

1 Like

I went ahead and flashed my Sonoff Zigbee 3.0 Dongle Plus to FW v20220219 (the latest).

Just tried another reconfigure on the ‘offline’ switch.

Debug 2022-10-29 14:31:34Received MQTT message on 'zigbee2mqtt/bridge/request/device/configure' with data '{"id":"Living Room Dimmer (Back)","transaction":"l6ing-1"}'
Info 2022-10-29 14:31:34Configuring 'Living Room Dimmer (Back)'
Error 2022-10-29 14:31:44Failed to configure 'Living Room Dimmer (Back)', attempt 2 (Error: Bind 0x943469fffe089d93/1 seMetering from '0x00124b0024c16b95/1' failed (AREQ - ZDO - bindRsp after 10000ms) at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/src/utils/waitress.ts:64:35) at listOnTimeout (node:internal/timers:559:17) at processTimers (node:internal/timers:502:7))
Info 2022-10-29 14:31:44MQTT publish: topic 'zigbee2mqtt/bridge/response/device/configure', payload '{"data":{"id":"Living Room Dimmer (Back)"},"error":"Failed to configure (Bind 0x943469fffe089d93/1 seMetering from '0x00124b0024c16b95/1' failed (AREQ - ZDO - bindRsp after 10000ms))","status":"error","transaction":"l6ing-1"}'

Just fyi there is a newer firmware available in the dev channel that is supposed to improve large network stability

Yea, but that states “larger networks” to be 100+ devices. I’m at 12. I can certainly give that a shot, but are there other things I should try - for diagnosing the ‘offline’ issue with one of my two switches? Could it just be a lemon?


Sorry didn’t mean to direct that at you. Saw a few people mention that they had large networks and wanted to share if that may be a reason for network performance issues

Here’s a diagram of my house along with where the various Zigbee devices are:

ZHA’s visualization shows 255 from the coordinator to the switch in the same room, and 220 from the coordinator to the switch in the upper bedroom on the right. 103 from the coordinator to one of the switches at the entrance (bottom of pic), and that switch is also marked as “Device is offline”. 84 from the coordinator to the other entrance switch, and 115/108 between the two entrance switches (which are right next to each other in the same box). Those two entrance switches I had some trouble pairing, but was able to get it to work by moving the Zigbee dongle around.

And the one in the Master Bedroom is the one I couldn’t get paired until I moved the whole HA computer closer (I’ve since set up ser2net on a MacBook and a socket:// connection in ZHA, so I can more easily move the coordinator’s antenna around the house for testing, but the permanent setup is for the coordinator to be in the bottom bedroom where the green dot is). The Master Bedroom switch also shows “Device is offline”, along with a 30 connection to the S40Lite in the kitchen and a 34 connection to the coordinator.