Blue Series 2-1 Signal / Routing / Performance Issue Troubleshooting Thread

Hey all,

In reading through some of these threads, it seems apparent that there are some issues with either signal, routing and overall performance with the 2-1’s, so we’d like to gather some information to get to the root cause and fix it.

This definitely does come as a shock to us as we didn’t experience this in beta, nor have any of the production units we’re testing experienced this, but regardless, we have the manufacturer looking into this, some of our beta testers as well as Eric and I.

The purpose of this thread is to gather as much information as possible and have a consolidated thread to report issues.

If anyone who is having these problems could take 5-10 minutes to fill out this questionnaire, that would be very beneficial so we can try to narrow it down.

If the iframe isn’t working above, here is the direct link: Blue Series 2-1 Switch Signal Poll

Very sorry to all those who are experiencing issues and please know that we will get to the bottom of it together.

4 Likes

Apologies if I miss anyone, but from my informal attempting to keep track of people with outstanding issues… @1337joe, @Azrael, @dahanc, @Donkey545, @epow, @huynh.kong, @imagio, @isowyn, @Jcol34, @logrec, @roger.hillson, @tony.gresset, and @wogfun I believe all of you still have open issues of some kind, whether it be joining or routing through the Blues. If it was resolved, please ignore me, but just wanted to make sure you saw this thread get opened and the form to help identify root cause and get this sorted!

5 Likes

I had quite a few issues in home assistant with ZHA (on raspberry pi 3) with my sonoff coordinator. I was unable to pair any of them in the first 10 times - i tried air gapping the switch and manually putting it in pairing mode. I opened the debug logs when pairing and noticed that I was getting a ton of traffic from my coordinator trying to find a few sengled smart bulbs that were offline because they were switched off at the outlet. I removed the bulbs and was able to pair the switches instantly

6 Likes

That’s really interesting, presumably just too much traffic trying to check on those bulbs?

Yea it was a ton of traffic for that and potentially my old rpi 3 is having some trouble processing everything? I’m not sure exactly how zigbee works but it could have also been overflowing the message buffer for the nearest zigbee router (or the sonoff coordinator) and causing the pairing request to not complete within the 20 second pairing window. Either way it is probably not specific to the switches :slight_smile:

For ease of finding it here’s the thread about my troubles with routing Sengled bulbs Blue series routing trouble? - #25 by epow

tl;dr is – sengled bulbs really don’t want to route via blue series for more than a few minutes, they will quickly drop off the network rather than continue routing through them

1 Like

I forgot to add after filling out the form that I noticed that the switches will not route through one another even when they are just a few feet away from one another.

2 Likes

The switches not routing through each other was my entire problem as well. I’ve currently solved it by adding a couple IKEA devices, but I only have two of those currently, which have to be online for half of my switches to connect.

3 Likes

I’m using hubitat and have had very hard time pairing and keeping the connection. Unless the switch is very close (<10 ft) with LOS to the hub or a router it doesn’t seem to work. I get LQIs around 0-5 for a dimmer within 14ft with LOS. None of my edge devices use them, but I suspect that is because their LQI is so low.

2 Likes

Using Zigbee2MQTT via Home Assistant add-on with a Sonoff stick. First couple of switches paired up pretty quick. Tried 3 more after that and they won’t pair despite air gaps, flipping the breaker, holding config and up button to go into pairing mode (the latter of which doesn’t always seem to work even if I release the buttons in the correct order).

One of the switches that won’t join is within 24" of the first switch I installed that joined without issue. I just took it back out and will pop it open and have a look at the antenna.

Edit: Popped open the switch and the antenna looked fine I guess. No obvious sign of damage. Also, I’m now up to 4 switches that refuse to pair. These are all out of the same 10 pack so next step I guess is to try a switch from the other unopened 10 pack I have. Frustrating experience so far.

1 Like

I’ve started installing my 10-pack of Blues. So far, one switch has issues. I opened a ticket, and Nate suggested I post here as well.

The switch has issues in both places I tried installing it, and when I swap it out for another Blue in the same location, that switch works. The “bad” switch is difficult to get to pair. And when it does pair, most of the configuration options are missing on the hub, and it doesn’t report any status back to the hub. Factory reset, re-pairing, and refreshing don’t help. It seems to be specific to this one switch (so far.)

FWIW, I’m using ZHA on Home Assistant.

Edit: I’m now up to 2 out of the 8 switches I’ve tried showing this behavior. Again, if I swap out the “Bad” switch with another, the new switch works in the same location with the same wiring. To me it really looks like there are some defective switches.

1 Like

This seems to be my issue as well using HA ZHA and Sonoff dongle with the TI chip.

I have plenty of switches that are well within range of each other and would have expected my network coverage to expand as I installed and connected more switches, but they refuse to route to one another and I am limited by proximity to the controller/other routers. I have some wall plugs on the way to see if I can patch the holes in the network as it were and get everything paired up. I may end up placing some dedicated routers around in the attic if the routing issue doesn’t get resolved, which might just be best practice anyway considering the weird layout of my home.

Otherwise I love them. Hands down the best smart switch on the market.

1 Like

I had a location that absolutely would not pair up after trying four different switches. A possible solution I thought would be to pair a switch at a known working location and then move it back to the “problematic” location. Results? Worked like a charm. Instant response and no issues at all.

Anyway, just an idea if you switch is being stubborn about pairing.

I wonder if the pairing process is more sensitive to LQI/RSSI vs. just using the switch?

3 Likes

I ended up adding a bunch of smart plugs as routers and that has helped some. However the switches still won’t wont route to one another even when they are in line of sight and just a few feet apart.

2 Likes

I think we may want to level-set some expectations here as well. Not all routers will connect to one another. The routing is managed by the protocol and isn’t controllable by the device, etc. For the ZHA map, the numbers indicate LQI between nodes, it’s refreshed every 4 hours and is Not indicative of routes. I believe that would be the same regarding Z2M, where LQI can provide some general information but also shouldn’t be viewed as needing to be above a certain threshold, etc. The general measure should be is the device working as expected or not. (Not saying throw all this data out the window, just hoping to clarify what info should be useful vs is likely noise as we try to figure out what’s going on)

One thing I want to mention now that I’ve said all that…those LQI numbers seem very low across the board. I’m not saying that’s inherently a problem, it could mean you’ve got a noisy environment or it could just be that different stacks calculate LQI differently and that’s all. Is this an townhouse/apartment or have neighbors where their wifi could be overlapping with the channel you’re using? I think we’d already checked your wifi and zigbee channels in the other thread for your own networks, but if you haven’t already it might be useful to check wireless signals with a wifi scanner to see if you’re getting interference on other channels as well?

2 Likes