Blue Series 2-in-1 Switch - Scene Control not working on SmartThings

I have my Blue Switch installed as a single pole Dimmer switch (Even tried as an on/off), and it works great, but I cannot get Scene Control to work on it at all. I am using the SmartThings Edge Driver, and I am now trying a basic Scene (See picture below). I set this up with my Red dimmer switch fine and it works. Also, I keep seeing “Couldn’t get device’s status.” Anytime I go to the switch’s page in the app, (Thinking this might have something to do with it) I have switched this out with another new one and same thing, so I don’t think it is the hardware. Any ideas? Thanks in advance.


Confirming you ought to be able to do this, as I just replicated what you are trying to do without issue.

I also have never seen the “Couldn’t get device’s status” error.

Wondering if it’s a driver issue. Since you swapped out the device and the issue remains. Open the device card. When you select driver, does it reflect "Inovelli 2-in-1 Blue series? If you select “Select a different driver” does it show other options? (It shouldn’t)

Yes I am using the Inovelli 2-in-1 Blue Series driver. When I tap select different driver it just shows “no results found”.

I also just tried to reboot the hub and uninstall reinstall the app. Same things as above.

We’re running the same driver.

I’d try uninstalling and re-installing the drivers.

Removed the switch from ST, then went online, uninstalled and reinstalled the driver, manually paired to hub ( hold up + config for 20 seconds which is a factory reset) and then pared it back to the hub with same issues. I have the V2 hub if that makes a difference?? I am lost…

V2 hub here as well.

@EricM_Inovelli ??

Are you seeing the “cannot get device status” on any other devices? I am not seeing that error on the blue series specifically, but see it frequently on other edge devices. I think it may signal intermittent communication issues or an app problem.

Not seeing that error at all in any other devices that are running edge drivers or any other device for that matter. Sorry

Maybe do an exclusion, factory reset and re-add. Worth a shot.

I sometimes see this if there was a problem with the ST platform during inclusion. Let me do some testing to try to see what is going on.

1 Like

So I did some testing with a new switch and watched the logs as I replicated your actions. I have not seen the error you saw or anything fishy in the logs. Can you screenshot all of the device details page? Are there any “cloud” icons on the device (showing that the inclusion didn’t finish correctly)?

I wonder if this is ST’s way of showing the signal degradation issue others are having? Can ST show the zigbee address?

Sorry Eric, I got an email SmartThings Maintenance email stating my hub’s firmware was going to update the hotfix to 0.45.11, so I waited till after that and removed it from the hub by deleting it, then factory reset again and added it back in, and it is working (Same as I did yesterday). I did notice before when it was not working that I saw more commands for the buttons, not just “Pressed, Held, 2x, 3x, 4x, 5x, and held down”, there were a lot more, so something was messed up.

I couldn’t have been signal degradation; the hub is directly below the switch…

Thanks everyone for the quick responses, even though I’m not sure what really solved it…

2 Likes