Blue series effects when a smart bulb mode dimmer

I couldn’t find a thread on this, so hopefully I’m not starting a redundant thread. Using Z2M and Home Assistant, I’m finally working on setting up my Blue series switches to control dimming of my smart bulbs. Currently, I’m not using binding, because these bulbs are on the Hue bridge (for now).

The problem I’m running into is I want to replicate the experience of a Blue series switch in Dimmer mode with SmartBulbMode disabled. Functionally, I have this working via a sync automation, but it’s constantly resetting the full LED bar to effect: solid with color: 85, level: 10, duration: 255 after showing the brightness level briefly–I’d really prefer it to continue showing the brightness level indefinitely like a Blue Series switch with SmartBulbMode disabled. Something like setting LoadLevelIndicatorTimeout: 11 (Stay On) when using a switch with a load on it.

I first compared settings for my test switch to another switch I have in dimmer mode with SmartBulbMode disabled and matched them (save for keeping SmartBulbMode enabled on my test switch). I tried setting ‘Effect’ to off and clear_effect, but it keeps going back to solid when I interact with the switch. Next, I tried setting the duration of the effect to zero, similar behavior. I tried a factory reset, but the behavior continues. Given the observed behavior, I suspect this is either something funky in Z2M or is defined directly in the firmware (I’m on v2.15).

Does anyone know how I can prevent this behavior? My fallback plan is to simply set clear_effect at the end of my brightness sync automation, but it seems like that should not be unnecessary.

Here’s the specific configuration that seems to be “permanently” stuck on my switch. I can change these inputs and see them take effect on the switch, however they constantly get reset with what’s in this screenshot:

That configuration is also squashing these:

This behavior reliably continues every time the switch is turned on and off (or dim level is adjusted).

Sigh. I am dumb. I thought I had disabled all other automations related to this switch, but I missed one and it was causing this behavior :man_facepalming: