Blue Series Fan Switch and Smart Fan Rebooting


I have 4 rooms with Big Ass Fans Haiku L fans, and the Blue Series 2-1 Fan Switches. I’ll say the ONLY place I’ve found on how to set the switches into “Smart Fan Mode” is the manual configuration GIFs on the instructions page; It doesn’t appear to be written down anywhere. (actually found it while searching google when writing this article, but can only put 2 links because I’m a new user, and the graphics below are more useful to this post) And all of the links to how to set it up only point to Samsung and Hubitat multi-scene configuration.

So to the problem. In 2 of my bedrooms, when I have both functions of the fans on (light and fan), it appears to pull “too much” power and the fan reboots. In the other 2 bedrooms it’s fine.
Now, to add to that, in Home Assistant for the 2 rooms where this problem exists, there’s a setting for “Switch Type” of “Single Pole”, “3-Way Aux”, “3-Way Dumb”, and “Single Pole Full Sine”. I saw a reddit post that suggested we should use Single Pole Full Sine, but when I select that, I get a message in HASS that says “Failed to call service select/select_option. Failed to write attribute switch_type=<InovelliSwitchType.Single_Pole_Full_Sine: 3>: <Status.INVALID_VALUE: 135>”.
Office Switch (Has the problem)
Jason’s Switch (Works fine)

Your Haiku L fans have DC motors. The Blue Fan Switch was designed and is rated for AC motors only. That may very well be the cause of the reboots. I’m surprised that it works at all with the other two fans.

So best to just bypass the switch and use it COMPLETELY as a smart switch?

FWIW this will be fixed in a future HA release, that’s pulling from the attributes for the 2-1 light switch, not for the fan switch which doesn’t have the same options and is why you get the invalid value error.

Changing the parameters would be better handled through the Manage Zigbee Device option on the device page.

1 Like