Blue switch delay?

Yes, I know “switch delays” have been mentioned before…

New-to-me Inovellie Blue 2-1 switch. Connected to Home Assistant. All delays within the setup are set to zero (that I can find). Switch set to “smart bulb mode.” Am running debug in Node-Red to see when the “on” and “off” messages are returned from the switch. This is taking a full three seconds to occur. Messages from Home Assistant to the Blue switch are instant – this isn’t a matter of Zigbee connection strength. Using Inovelli firmware version 2.15.

Would show you all the settings, but the switch has so many. Suffice to say that I’ve gone through and turned all delays down to zero. There is no load on this switch, it is just acting as a smart switch that I’ll use to control some smart bulbs in the room.

Should Node-Red debug info respond faster than 3 seconds to a button press of the Blue switch? I should think so.

Here’s some additional info on the switch configuration, taken from the Node-RED debug node:

{
“entity_id”: “light.mb_light_switch”,
“state”: “on”,
“attributes”: {
“supported_color_modes”: [
“brightness”
],
“color_mode”: “brightness”,
“brightness”: 255,
“action”: null,
“activeEnergyReports”: null,
“activePowerReports”: null,
“autoTimerOff”: 0,
“auxSwitchUniqueScenes”: null,
“bindingOffToOnSyncLevel”: null,
“brightnessLevelForDoubleTapDown”: null,
“brightnessLevelForDoubleTapUp”: null,
“buttonDelay”: “0ms”,
“defaultLed1ColorWhenOff”: null,
“defaultLed1ColorWhenOn”: null,
“defaultLed1IntensityWhenOff”: null,
“defaultLed1IntensityWhenOn”: null,
“defaultLed2ColorWhenOff”: 82,
“defaultLed2ColorWhenOn”: null,
“defaultLed2IntensityWhenOff”: null,
“defaultLed2IntensityWhenOn”: null,
“defaultLed3ColorWhenOff”: null,
“defaultLed3ColorWhenOn”: 180,
“defaultLed3IntensityWhenOff”: null,
“defaultLed3IntensityWhenOn”: null,
“defaultLed4ColorWhenOff”: null,
“defaultLed4ColorWhenOn”: null,
“defaultLed4IntensityWhenOff”: null,
“defaultLed4IntensityWhenOn”: null,
“defaultLed5ColorWhenOff”: null,
“defaultLed5ColorWhenOn”: null,
“defaultLed5IntensityWhenOff”: null,
“defaultLed5IntensityWhenOn”: null,
“defaultLed6ColorWhenOff”: null,
“defaultLed6ColorWhenOn”: null,
“defaultLed6IntensityWhenOff”: null,
“defaultLed6IntensityWhenOn”: null,
“defaultLed7ColorWhenOff”: null,
“defaultLed7ColorWhenOn”: null,
“defaultLed7IntensityWhenOff”: null,
“defaultLed7IntensityWhenOn”: null,
“defaultLevelLocal”: 128,
“defaultLevelRemote”: 128,
“deviceBindNumber”: null,
“dimmingSpeedDownLocal”: 0,
“dimmingSpeedDownRemote”: 0,
“dimmingSpeedUpLocal”: 0,
“dimmingSpeedUpRemote”: 0,
“doubleTapClearNotifications”: null,
“doubleTapDownToParam56”: null,
“doubleTapUpToParam55”: null,
“energy”: 0,
“firmwareUpdateInProgressIndicator”: “Enabled”,
“higherOutputInNonNeutral”: “Disabled (default)”,
“individual_led_effect”: {
“color”: 32,
“duration”: 15,
“effect”: “solid”,
“led”: “6”,
“level”: 79
},
“internalTemperature”: null,
“invertSwitch”: “No”,
“ledBarScaling”: null,
“ledColorWhenOff”: 21,
“ledColorWhenOn”: 170,
“ledIntensityWhenOff”: null,
“ledIntensityWhenOn”: 70,
“led_effect”: {
“color”: 52,
“duration”: 0,
“effect”: “medium_rising”,
“level”: 19
},
“linkquality”: 255,
“loadLevelIndicatorTimeout”: null,
“localProtection”: null,
“maximumLevel”: 128,
“minimumLevel”: 2,
“onOffLedMode”: “One”,
“outputMode”: null,
“overheat”: null,
“periodicPowerAndEnergyReports”: null,
“power”: 0.2,
“powerType”: null,
“rampRateOffToOnLocal”: 0,
“rampRateOffToOnRemote”: 0,
“rampRateOnToOffLocal”: 0,
“rampRateOnToOffRemote”: 0,
“relayClick”: null,
“remoteProtection”: null,
“smartBulbMode”: “Smart Bulb Mode”,
“stateAfterPowerRestored”: 255,
“switchType”: “Single Pole”,
“update”: {
“installed_version”: 16908815,
“latest_version”: 16908815,
“state”: “idle”
},
“update_available”: false,
“friendly_name”: “MB light switch”,
“supported_features”: 40
},
“last_changed”: “2023-11-22T13:24:57.134973+00:00”,
“last_updated”: “2023-11-22T13:24:57.134973+00:00”,
“context”: {
“id”: “01HFVK925EVBCXHYVMJX2AK3GP”,
“parent_id”: null,
“user_id”: null
},
“original_state”: “on”,
“timeSinceChangedMs”: 1335
}

I don’t know anything about anything but shouldn’t the value for “buttonDelay” be “0” instead of “0ms”?

These are the values as stored by Home Assistant when configuring the switch in the standard way. None of the numbers is followed by any units, which is fine as long as the programming understands the intended units for any given parameter (which I figure it does).

So, anybody? Anyone at Inovelli? Is this expected behavior? Do I have a bad switch? Is the programming bad? Have I messed up some setting?

Can you post the flow you’re testing? I can run it against my switch.

It is super-simple:

Using the Home Assistant “events: state” node, and both outputs connected to a debug node. I watch the debug output. Click the button, wait three seconds, debug data appears.

Here is the export of that flow:

[
{
“id”: “5f29f49fb3ec714a”,
“type”: “debug”,
“z”: “e0927317e8bb8cf4”,
“name”: “debug 5”,
“active”: true,
“tosidebar”: true,
“console”: false,
“tostatus”: false,
“complete”: “false”,
“statusVal”: “”,
“statusType”: “auto”,
“x”: 500,
“y”: 620,
“wires”: []
},
{
“id”: “7c9ede4314f41cb8”,
“type”: “server-state-changed”,
“z”: “e0927317e8bb8cf4”,
“name”: “”,
“server”: “516c2498.f1e86c”,
“version”: 4,
“exposeToHomeAssistant”: false,
“haConfig”: [
{
“property”: “name”,
“value”: “”
},
{
“property”: “icon”,
“value”: “”
}
],
“entityidfilter”: “update.annex_light_switch”,
“entityidfiltertype”: “exact”,
“outputinitially”: false,
“state_type”: “str”,
“haltifstate”: “on”,
“halt_if_type”: “str”,
“halt_if_compare”: “is”,
“outputs”: 2,
“output_only_on_state_change”: true,
“for”: “0”,
“forType”: “num”,
“forUnits”: “minutes”,
“ignorePrevStateNull”: false,
“ignorePrevStateUnknown”: false,
“ignorePrevStateUnavailable”: false,
“ignoreCurrentStateUnknown”: false,
“ignoreCurrentStateUnavailable”: false,
“outputProperties”: [
{
“property”: “payload”,
“propertyType”: “msg”,
“value”: “”,
“valueType”: “entityState”
},
{
“property”: “data”,
“propertyType”: “msg”,
“value”: “”,
“valueType”: “eventData”
},
{
“property”: “topic”,
“propertyType”: “msg”,
“value”: “”,
“valueType”: “triggerId”
}
],
“x”: 200,
“y”: 620,
“wires”: [
[
“5f29f49fb3ec714a”
],
[
“5f29f49fb3ec714a”
]
]
},
{
“id”: “516c2498.f1e86c”,
“type”: “server”,
“name”: “Home Assistant”,
“version”: 2,
“addon”: true,
“rejectUnauthorizedCerts”: true,
“ha_boolean”: “y|yes|true|on|home|open”,
“connectionDelay”: true,
“cacheJson”: true,
“heartbeat”: false,
“heartbeatInterval”: “30”
}
]

Your button delays and ramp rate settings are all good. These are the only settings at the switch level that can affect speed of turning on.

“linkquality”: 255 - Are you using a Conbee stick? It’s known to inacurately report linkquality to 255 and makes it difficult to diagnose connection issues. And with your settings looking correct, I’m definitely leaning towards zigbee connection issues. (assuming your HA hardware isn’t for some reason running at near 100% cpu)

What’s your Zigbee map look like? Can you post a screenshot of that.
Also ZHA or Z2M?
Which channel are you running your Zigbee network on?
And which channel is your WiFi router using?

1 Like

Finally got around to trying this. It takes less than a second (and my button delay is 500ms) for the debug info to show up. My switch is configured as an on/off switch. I’m using the Sonoff USB dongle (-P) .

action: null
activeEnergyReports: 10
activePowerReports: 10
autoTimerOff: 0
auxSwitchUniqueScenes: Disabled
bindingOffToOnSyncLevel: Disabled
brightness: 254
brightnessLevelForDoubleTapDown: 2
brightnessLevelForDoubleTapUp: 254
buttonDelay: 500ms
defaultLed1ColorWhenOff: 255
defaultLed1ColorWhenOn: 255
defaultLed1IntensityWhenOff: 101
defaultLed1IntensityWhenOn: 101
defaultLed2ColorWhenOff: 255
defaultLed2ColorWhenOn: 255
defaultLed2IntensityWhenOff: 101
defaultLed2IntensityWhenOn: 101
defaultLed3ColorWhenOff: 255
defaultLed3ColorWhenOn: 255
defaultLed3IntensityWhenOff: 101
defaultLed3IntensityWhenOn: 101
defaultLed4ColorWhenOff: 255
defaultLed4ColorWhenOn: 255
defaultLed4IntensityWhenOff: 101
defaultLed4IntensityWhenOn: 101
defaultLed5ColorWhenOff: 255
defaultLed5ColorWhenOn: 255
defaultLed5IntensityWhenOff: 101
defaultLed5IntensityWhenOn: 101
defaultLed6ColorWhenOff: 255
defaultLed6ColorWhenOn: 255
defaultLed6IntensityWhenOff: 101
defaultLed6IntensityWhenOn: 101
defaultLed7ColorWhenOff: 255
defaultLed7ColorWhenOn: 255
defaultLed7IntensityWhenOff: 101
defaultLed7IntensityWhenOn: 101
defaultLevelLocal: 255
defaultLevelRemote: 255
deviceBindNumber: 0
dimmingSpeedDownLocal: 127
dimmingSpeedDownRemote: 127
dimmingSpeedUpLocal: 127
dimmingSpeedUpRemote: 25
doubleTapClearNotifications: Enabled (Default)
doubleTapDownToParam56: Disabled
doubleTapUpToParam55: Disabled
energy: 0
firmwareUpdateInProgressIndicator: Enabled
higherOutputInNonNeutral: Disabled (default)
individual_led_effect: null
internalTemperature: 29
invertSwitch: 'No'
ledBarScaling: Gen3 method (VZM-style)
ledColorWhenOff: 170
ledColorWhenOn: 170
ledIntensityWhenOff: 1
ledIntensityWhenOn: 33
led_effect: null
linkquality: 116
loadLevelIndicatorTimeout: Stay On
localProtection: Disabled
maximumLevel: 254
minimumLevel: 1
onOffLedMode: All
outputMode: On/Off
overheat: No Alert
periodicPowerAndEnergyReports: 3600
power: 0
powerType: Non Neutral
rampRateOffToOnLocal: 127
rampRateOffToOnRemote: 127
rampRateOnToOffLocal: 127
rampRateOnToOffRemote: 127
relayClick: Enabled (Click Sound Off)
remoteProtection: Disabled
smartBulbMode: Disabled
state: 'ON'
stateAfterPowerRestored: 255
switchType: Single Pole

image

1 Like