Blue Switch not recognizing multiple presses for routines

Hi all - trying to troubleshoot and would appreciate thoughts. Installed 7 blue switches in my recently finished basement. For a few of them, they won’t recognize multiple presses for triggering routines (I’m a SmartThings user). They’ll recognize double tap up for full power, but not for triggering routines. I’m guessing the double tap up for full power works differently than routines but not sure if reading this will trigger a thought for anyone. The switches I’m mostly seeing issues with are multi-way with aux add-ons. Any thoughts appreciated!

Try increasing your button delay


Hey, I’m actually looking into this as well and I can’t tell if this is a SmartThings issue or what because I’m experiencing the exact same thing and it only happened within the last week or so when I was messing around with my network.

The same driver is being picked up by the devices, but some just simply don’t register multi-taps and they don’t show up in the history. These same switches did a week before just perfectly, so I don’t know what is going on.

@EricM_Inovelli – I guess I’m not the only one going crazy with this. I’ll work on the CLI Logging tonight and see what I can provide.

@kevin.espinosa Are you using the 2/22/23 PRODUCTION driver?

Interesting, glad it’s not just me!!

I am using the Blue 2-1 driver from the official Inovelli Edge Drivers channel. I can’t see the last date it was updated and it doesn’t indicate beta vs. production, but it’s the official channel so I’m guessing production.

FYI, it’s in the Driver menu under version. But since all of your Blues will use the same driver and since it’s just a few of them, I’m now thinking it’s probably not the driver version.


Ah, got it. Thanks! So, yes, I’m using the same driver in your screenshot.

1 Like

By the way, I tried the n reading button delay with no success.

Just curious if there’s anything we can do to troubleshoot this if it’s not just me experiencing the issue.

There should be a driver update that got pushed yesterday. On one of the switches can you do a factory reset and then add it back to the network? You don’t have to remove it from ST at this point.

1 Like

This appears to have worked. It’s not recognizing any of the prior parameter changes but I see you have added a parameter configuration resend option in the settings with “yes” and “sure” so it looks like that’s the solution. Thanks for solving this! So I just need to factory reset, re-add, and then re-push parameter configurations for any impacted switches, right?

1 Like

Yep, that should do it.

I don’t mean to hijack, so please let me know if this should be a new thread, but I saw this come up in my email rollup, and I recalled that I have been having some intermittent issues with triggering automations on Home Assistant relating to double press up or down or pressing the config button.

For example, I setup an automation on my porch lights to set the brightness to 25% when I single-press the config button, but that almost never seems to work. In my office, I setup an automation for double press up or down to turn on or off the ceiling fan. That only seems to work sometimes. I think it works better if I single press the paddles a little bit first to toggle the light, then the double press automation seems to work better?

Hard to say.

I’m running ZHA.

What do you have the button delay setting at? Maybe it is too low and you aren’t pressing the button fast enough? Try to increase the setting to see if it is more consistent.

By the way, while of course we’d all love to never have issues, the responsiveness of the Inovelli team when there are issues is incredible and thank you for adding the ability to re-send configurations to the switch. Always looking to improve and I love buying your switches because of that. Keep up the great work! My house is getting darn near close to 100% Inovelli switches at this point though I haven’t committed to smart switches in bathrooms or some closets yet, lol.