Blue switch stuck in smart bulb mode (relay stuck on?)

A bit of backstory: I have a couple of Sengled Zigbee bulbs that are known to have issues falling off the network with these switches. I have them behind one blue switch in smart-bulb mode, so the lights can be individually controlled through group binding or ZHA in Home Assistant. Patiently waiting for the firmware upgrade that will evidently solve that issue.

The switch is a single pole and wired with a neutral.

Up until recently, when the bulbs would drop off the network, I’ve been able to turn off smart-bulb mode, toggle the light switch a couple of times to restart the bulbs, then go back into smart-bulb mode to allow the bulbs to operate as usually.

Now, I am unable to get get it to into on/off, non-smart-bulb mode. Setting the toggle in Home Assistant appears to work, as it never gets reverted by the software, but toggling the switch does not turn power off at the lights, and the lights can be still be turned on and off individually. I do have the relay click turned off normally, but turning that back on also appears to do nothing, as if the relay is stuck on. I’ve also noticed that power monitoring never changes from 0.0W, where my other switches do update.

Things I have tried:
1.factory reset
2. removing the switch from my network and re-adding it
3. pulling the air gap for a fairly long period of time
4. setting the switch to on/off by holding up and tapping the config button 3x

Nothing seems to be working to be able to set the switch to non-smart bulb mode.

Any help or advice is greatly appreciated!

I would remove and factory reset it at this point, since the other things haven’t worked.

As in remove from network and factory reset? Both of those are 1 and 2 of what I’ve already tried :confused:

Yes, I see that now. When you re-added it did you confirm that the settings seemed to be reset to the default? The two button concept on the Blues seems to cause some issues in actually factory resetting. It does not make any sense that you should not have been able to push new parameters to a factory reset switch.

Yes, everything seems to have reset as expected, in terms of parameters visible from home assistant (especially smart bulb mode being turned off), but it is still supplying power to the lights…

Any chance the switch got overloaded or shorted out?
When MOSFETs fail I believe they can fail in this way.
Just a theory, but I’ve had other smart switches/MOSFET do this to me.

It is being used simply for lighting, so I can’t imagine that it would have been overloaded. I suppose it could have shorted somehow, but I also can not think of any reason that would have happened…

Could always be just bad luck of an early failure…
I know I cooked a Leviton Z-Wave switch based on a Mosfet design once when yours truly had a momentary short… Doesn’t take much of a little spark from a dead short to let the magic smoke out… -as I know from experience… :slight_smile:

What is your load?

The switch is reporting 0W, but the 2 bulbs report 8.6W each. So 17.2W.

I’m just going to throw this out there, not as a solution to the main issue but as a recommendation. It seems like what you’re doing here by turning SBM off is so that you can cut the power to the bulbs. Turning off SBM, toggling the switch, turning it back on… that’s just a lot of work. The exact same thing can be achieved simply by pulling the airgap. It will cut the power to the bulbs just like turning the switch off will do when SBM is disabled. There should be no need to turn off SBM unless you are swapping the bulbs out to regular dumb bulbs.

As per why it’s stuck in SBM, you’ve already tried my recomendations so I’ve got nothing to add there.

On the contrary because I can automate it :grinning:
Prior to doing that, it was useful for fixing the problem for simulated occupancy when out of town.

Either way, it sounds like I may need to try to RMA this one, as even if the firmware fixes the issue with the singled bulbs, it would be preferable to have a fully working switch.