Cannot reset Parameter 51 on LZW31-SN

I’ve upgraded all of my LZW31-SN dimmers to firmware 1.48. One of my dimmers is stuck with paramater 51 =1. I have tried to reset it through the new Hubitat driver and the firmware update driver to no avail. I performed a hard reset, re-added it to Hubitat, and the value still remains as a 1.

Has anyone experienced this before? How did you resolve it?

Yup I’m having the same issue and can’t figure out how to fix it either. My problem actually occurred on version 1.47. I didn’t realize this before upgrading to 1.48 and now on 1.48 I have the same issue you are reporting, I can’t change parameter 51 back to 0.

Interestingly, even through the parameter is set to 1, the dimmer switch is not acting like a dimmer, it does full on or full off. Additionally, I cannot set the color of the dimmer to white either.

I had an issue with the color strip not going white when the 2nd firmware (for holtek MCU) didn’t flash properly. In my case I found I needed to wait a little after flashing target 0 to flash target 1, then it was successful.

I also have this problem. I would like to get the 51 parameters changed to 0. I have tried other drivers and other browsers even within Hubitat, and the configure button seems to not do anything when I put 51/0/1. Have you figured out how to make this work, yet?

I continue to have this problem and have been unable to find a solution. I tried contacting support but they basically said they don’t really know and try the forums. Unfortunately at this point I’m stuck. I plan to remove the switch this afternoon. Hopefully this will get fixed at some point and I can try the Inovelli switches again.

Worst case you could do a factory reset. Hold config button for 30 seconds. Don’t know enough about hubitat to give other help.

I was able to fix this by applying firmware 1.35 from and then upgrading each firmware until I got back to 1.48. I don’t know if you could go directly from 1.35 to 1.48, so I went through each one. This completely fixed the issue for me.

1 Like

@EricM_Inovelli We could sure use your advice here.

Two things to try. First, make sure you watch the bin file flash completely and successfully. You may even want to do this twice to make sure it is flashed properly.

Second is to toggle the setting to 1 and then back to 0. Even if it is reporting 1, still set it to 1 and click “Save Preferences”. Then set it to 0 and “Save Preferences”.

Edit: Also do this for parameter 52.