Can't change switch LEDs on Zigbee2MQTT 1.36.0

This works fine on Zigbee2MQTT 1.35.0. Is anyone else experiencing this? I was able to revert the update w/ a backup and that fixed it.

I’m currently using a blueprint to make it easier to control but even trying to do it directly through ZHA or Zigbee2MQTT doesn’t have any effect. The LEDs only respond to hard-wired lights but nothing from HA.

I’m not sure its Zigbee2MQTT because my custom script for notifications is still working in 1.36. I’m sending directly to MQTT like the following:

    payload = {
        "led_effect": {
            "effect": effect_value,
            "color": color_value,
            "level": level,
            "duration": duration_value
        name = state.get(f"{entity}.friendly_name")
        command_path = f"zigbee2mqtt/{name}/set"
        mqtt.publish(topic=command_path, payload=message_json)

I’ve tried switching back and forth between 1.35.0 and 1.36.0 and the behavior is 100% reproducible in my case.

I can’t control the LEDs on any of my switches in any way after upgrading. I’ve tried restarting Home Assistant afterwards but that doesn’t help.

It’s annoying that updates can’t be dismissed so the indicator on the Settings button is just there 24/7 now since I can’t upgrade.

1 Like

I’m running 1.36.0-1 and no issues changing LED’s here

Running 1.36.0 here and also having no issues changing LED colors.

@Eric_Inovelli Any suggestions for how I can help provide some more troubleshooting details on this? So far it’s just me but I doubt I’m actually the only one with this issue given how easy it is for me to reproduce and I don’t feel that I’m doing anything particularly special/unique here.

@EricM_Inovelli - can you help with this?

Can you help describe what you are trying to do? Are you trying to activate a notification? Can you provide the steps and I can test it on my installation?

What I have are, for the most part, switches that control two lights at a time (up_single will toggle one light and down_single will toggle the other). When the “up_single” light is on, I’ll light up LEDs 1-3 (the top ones). When the “down_single” light is on, I’ll light up LEDs 5-7 (the bottom ones).

The lights they control are generally smart lights but sometimes they’re not.

When I update to Zigbee2MQTT 1.36.0-1, this all stops working. I also cannot apply any LED colours directly through HA (either through ZHA or the Z2M “Exposes” page for the switch.

When I revert back to v1.35, it’s all good again.

I have two switches that control only 1 non-dimmable dumb light each, connected directly. On these, when I press “up_single” or “down_single”, it will do the default animation of lighting up the LEDs from the bottom to the top. Even on these lights though, I still can’t set any of the LEDs though Home Assistant; the LED controls in the “Exposes” page for the switch just doesn’t seem to do anything.

I’m not sure where to find where there might be an error thrown so I’m not sure what else to try at the moment.

This is the blueprint I’m using to change the LEDs through HA in the actual “notification”: LED Effects with Inovelli Blue and Zigbee2MQTT/Home Assistant - #19 by EricM_Inovelli

I’m pretty confident that the issue isn’t in the blueprint though because it doesn’t work if I try to change the LEDs myself through the ZHA or Z2M UI.

In case it’s unclear what I mean by “Z2M UI”, it’s this:

Clicking “apply” works fine in 1.35.0 but in 1.36.0 it doesn’t seem to do anything.

You may want to try reimporting the blueprint. There’s at least some discussions of that solving similar problems: [Z2M] Inovelli Blue Series Switch LED Notification Script (VZM31-SN, VZM35-SN) - #64 by zanixmechanix - Blueprints Exchange - Home Assistant Community

Well… at the current moment I can’t explain all of the behavior as to why I couldn’t control the LEDs from within Home Assistant – although now that I recall, I’ve had this issue before (still haven’t ever nailed it down exactly why this happens)…

But re-importing that blueprint seems to have just fixed everything when on 1.36.0 as you and the other guy in that thread said.

If I come across the issue again where I can’t manage/test the LEDs from within the Z2M UI, I’ll follow up in a new thread but I’ll reference this one.


Thanks for following up. I did test yesterday using an led_effect from my z2m gui and it seemed to be working. I was on 1.36 but I also tested the edge branch. Good to know a workaround @rohan but it would be nice to know what happened. At least this thread will be useful to anyone else that stumbles upon the problem.

I believe it has something to do with this change in Z2M 1.36. The older version of the Blueprint (prior to October) didn’t handle that correctly so reimporting brings in that change and makes it work again.

Previous model name:
Inovelli 2-in-1 switch + dimmer (VZM31-SN)

New model name:
2-in-1 switch + dimmer (VZM31-SN)
1 Like

Yep. Home Assistant doesn’t automatically update blueprints if they have been updated. You have to re-import them manually.