Can't control red dimming from zwave?

Having some trouble getting zwave-JS to be able to control the dimmer. From the zwavejs2mqtt control panel, I’m able to set all the config values, can trigger LED animations, etc, and it gets scene notifications from tapping the buttons as expected.
But when I try to set the brightness target value it doesn’t change, and I get the following in the log. Same if I do it from home assistant.

2021-04-24 00:44:15.895 INFO ZWAVE: Writing 35 to 9-38-0-targetValue
00:44:15.905 DRIVER » [Node 009] [REQ] [SendData]
│ transmit options: 0x25
│ callback id: 12
│ session id: 2
│ request updates: true
target value: 35
00:44:15.914 DRIVER « [RES] [SendData]
was sent: true
00:44:16.080 DRIVER « [REQ] [SendData]
callback id: 12
transmit status: OK
00:44:16.219 DRIVER « [Node 009] [REQ] [ApplicationCommand]
session id: 2
more updates follow: false
status: Fail
duration: [Duration: 0 seconds]
2021-04-24 00:44:16.225 INFO ZWAVE: Success zwave api call writeValue { success: true, message: ‘Success zwave api call’, result: undefined }

Similar if I try to trigger a level change action.

2021-04-24 00:45:21.846 ERROR ZWAVE: Error while writing true on 9-38-0-Up: startLevelChange failed
2021-04-24 00:45:21.846 ERROR ZWAVE: Unable to write true on 9-38-0-Up
2021-04-24 00:45:21.847 INFO ZWAVE: Success zwave api call writeValue { success: true, message: ‘Success zwave api call’, result: undefined }

If I try to set the “duration” property for the target value, I get this pop up message in the corner.

Driver: Multilevel Switch: “duration” is not a supported property

It’s running on fw 1.52 and 1.43

Don’t know a thing about HA, but make sure you don’t have Disable Remote Control enabled.

I went back to 1.48, and it works now. I don’t see a parameter for Disable Remote Control, maybe it’s only in 1.52, but would you mind checking what parameter number it is if you see it?

I tried looking for the parameter before and couldn’t find it. In SmartThings, it can be enabled via the devices settings in the app. You can even create a child object for it. So if it’s not a parameter, I’m not sure how it gets implemented. One of the HA gurus here ought to know.

You can’t get to it through HA but you can get to it through zwaveJStoMQTT.

It has different groups of values. The configuration group doesn’t have it and those are the ones available in HA. It’s in the Manufacturer Specific group.

Awesome thank you!
If anyone else stumbles on this, it’s in zwavejs2mqtt device settings, under “protection” category “rf protection”. Somehow the default value after updating firmware was 10 which doesn’t even seem valid.

1 Like

You’re right, I must have had both expanded at the same time.

Also yes, options are 0-2 so 10 would be wrong.