Can't include / exclude LZW31-SN in a new ZwaveJS2MQTT setup

I have a brand new Home Assistant (Haasio) instance running on a raspberry pi 4 2gb, in preparation for setting up my first Zigbee and Z-wave networks I purchased a HUSBZB-1 Nortek Secure & Control stick and updated both the Zigbee firmware and the Z-wave firmware (It now runs Z-wave version 6.09 as per this guide)

All of that setup went very smoothly, and my Zigbee devices are doing great, but when it comes to my only Z-wave devices, two LZW31-SN, I can’t get either of them to pair (include) with ZwaveJS2MQTT.
I figured I would use ZwaveJS2MQTT rather than sinking time into the soon to be deprecated OpenZwave, but thus far I’ve had no luck even getting the hub to talk to the switch.

The logs look good inside of the Hass supervisor (as far as I can tell) in that it can connect to the stick and set up the basic Z-wave network. When I click include or exclude it will go all the way through it’s countdown timer until it times out (as you would expect). However, when I try to pair the device, it stops the countdown prematurely (meaning that the Z-waveJS container and the switch had some sort of communication - normally it would countdown to 0) but then the hub says ‘Inclusion stopped, no changes detected’ and nothing happens. The switch flashes red.

I’ve tried:

  • Factory resetting the switch
  • Checking the signal strength (it does turn green, turns red after but def turns green for a bit)
  • Excluding the node by pressing the program button 3 times (same thing happens as with inclusion)
  • Including the node by pressing the program button 3 times

What should I do? Is there a configuration I’m missing like with the open-Z-wave setup? Should I try to pair with the stick from another device and then move back to my pi?

I made a short video to show you exactly what I’m talking about

Thanks for the help

Sounds like you might be pushing the range. I didn’t get RELIABLE z-wave mesh until I had about 5 devices. I’d recommend trying to get the pi closer (within 10ft line of sight), seeing if that works, and then if not trying to pair via another solution (since the network info is stored on the stick, if you can get it to pair via ANY solution it will work in Z2M).

I just measured it and the distance from the HUSBZB-1 to the switch is 4’ 10"
It is under a bed that is pretty close to this device, my goal is to have this switch be the first in my Z-wave network because it’s a powered node and can repeat to other accessories that are farther away.
The issue is adding it to get the ball rolling.

Sounds like you have done what I would do. Are you sure that the Z2M instance is working correctly (you can see the hub and initiate pairings)? Can you try the second switch and see what it does?

Sure, I put my second switch in a temporary housing so I could move it as close to a PC as possible and then fired up Z-Wave PC Controller 5 from SiliconLabs to see if I could troubleshoot.

Everything about the controller looks fine, under the network tab I can click “add device” and the inclusion starts but I get the exact same behavior out of this software too… Like, I know the controller is aware of the switches because when I start the pairing (3x press on the button) it stops the inclusion immediately, but always with a failure message. Like in this screenshot:

At least I can rule out ZigbeeJS2MQTT as the issue, it’s down to the Sigma Designs ZW0500 being incompatible with this switch… Except that can’t be true, right? Other people have to have the HUSBZB-1 stick and these switches?!

Did you do an exclude first w/the PC Controller? I see the entry at 18:13 but don’t recall of the top of my head what an exclude log looks like. If you didn’t, try excluding it first, then adding.

It’s true that I seem to have fewer problems excluding, as you can see here after factory resetting the switch I am able to remove it in one shot using Network Wide Exclude. Network Wide Include (which can apparently try multiple times) is a different story.
You can see it fail to add the node over and over again here until the pairing timer on the switch itself times out.

I’m thinking of downloading the Z-wave sniffer from Silicon Labs, since this firmware is apparently compatible with it. I heavily dislike how vague the messages are in both this log and the ZwaveJS2MQTT logs :frowning:

Update: It can’t sniff :confused: So much for that strategy
I am able to add the switch’s DSK in the smartStart menu, after doing that I see it will try to add the node in a constant loop without me even starting the inclusion, but it’ll never succeed.

I guess this explains those random log entries I was getting in the ZwaveJS2MQTT log, those were smart start packets. It’s a shame that even with a DSK it can’t seem to do anything.

Yes lots of HUSBZB-1 in production units with your setup.

So this sounds like a hardware issue.

Does the computer see the USB in device manager as what it is, or an unknown device? Did the proper drivers install? Is the SL software seeing it as what it is, correct COM port, etc? That seems like it is all right (to initiate NWE, NWI).

So then I move to the stick itself, have you tried a :“Reset” on the stick? This will delete any current network information that might be gumming it up. Have you checked if Nortek has a software for firmware updating, perhaps it needs a firmware update, or perhaps the firmware didn’t flash fully and needs a push?

Do you have a different Z-wave device that you can try? If more than one pairing fails in the same manner it SEEMS that the UZB is the issue.

@kreene1987 You’re right, it was my controller’s firmware. For some reason with the Silicon Labs 500 series controllers, one flash isn’t good enough. I ran it again this weekend and I’m able to add the innovelli switches to my network now :slight_smile:

Thank you

1 Like