Cant set LED indicator intensity

So I can change color, change notifications, but for some reason I can not change the indicator intensity; both when on or off.

Heres my command Im sending it through node, red. No errors, but nothing happens. As I said, this is the same stuff I use to change the color, just change the parameter # and data, obviously.

Even tried it through HA developer tools. I was able to set color, as I said. Thats the first picture, you see the command and the response. Then I try to set intensity, you see the command but not response…

Setting parameter 13, works.

Setting parameter 14 or 15, no good.

And I can change brightness directly from switch.

I set a bunch of zwave config parameters in my automations but never had a need to automate the LED intensity. I’m curious what the use case would be?

Anyway, I tried setting this the same way that you did from the dev console and I had the same result. I did a bit of searching and found a similar question that was answered on the Home Assistant forums:

“The XML defines this config parameter as a “list” type. When the parameter is a list, OZW (or perhaps the Python OZW API that Home Assistant is using) expects to be given the item label, not the raw value.”

In this particular case, you will want to set the value to the label text contained in the zwcfg_*.xml file. In my case, the value is “0%” - “100%”

			<Value type="list" genre="config" instance="1" index="14" label="LED Strip Intensity" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="10" vindex="5" size="1">
				<Help>This is the intensity of the LED strip. Range: 0-10 Default: 5</Help>
				<Item label="0%" value="0" />
				<Item label="10%" value="1" />
				<Item label="20%" value="2" />
				<Item label="30%" value="3" />
				<Item label="40%" value="4" />
				<Item label="50%" value="5" />
				<Item label="60%" value="6" />
				<Item label="70%" value="7" />
				<Item label="80%" value="8" />
				<Item label="90%" value="9" />
				<Item label="100%" value="10" />
1 Like

Edit# 4

Got it! Thanks


Try the value in quotes Ie “10%”. You can change the zwcfg file but only when home assistant is stopped, otherwise it will save over your changes. I downloaded a zwcfg file that has all of the possible configurations, I’ll try to find it later. but you may even need to update it yourself if there is a new firmware that comes out with new parameters

1 Like