Can't z-wave include red series with Hubitat

Let me just start with this, so I don’t get the “canned” responses for people.

I have the latest Hubitat hub. Before today, I had 20 Leviton dimmers, 9 Leviton switches paired with Hubitat. I got my new Inovelli dimmers and switches. I manually excluded all Leviton devices from Hubitat. Reset z-wave on Hubitat. Shutdown hub. Pulled power from hub for 30 seconds. Powered back Hubitat.

Using Inovelli driver from Hubitat/inovelli-dimmer-red-series-lzw31-sn.groovy at master · InovelliUSA/Hubitat · GitHub

Ok, wire up 1st Inovelli dimmer. I get to this point


Nothing in logs, device never comes online. When I put Hubitat in exclusion mode, I get “Unknown device excluded”

Tried 3 other dimmers (bought 20 dimmers, 10 switches). All the same, stuck on “initializing”. Now at this point I have excluded, factory reset, rebooted Hubitat, cut power to inovelli devices via electrical panel, 4-5 times. I have also tried from ground-zero, both z-wave “secure join” modes (all secure and locks/garage doors only). Resetting everything to ground-zero before switching these modes.

This is extremely disappointing. Already pulled off the tabs on some of the dimmers. Wondering if I should be requesting a refund and go HomeSeer? The 2 WD200s I have seem to work flawlessly, I can unpair and repair over and over again. Connected one of the Levitons I just unpaired this morning, paired no problem. I’ve tried 4 Inovellis dimmers straight out of the box, brand new… All the same… stuck on initializing during z-wave inclusion.

How far is the first switch from the hub?

at first i had the hub in its usually place, the first dimmer i tried to add was one interior drywall away (< 20 ft), but since then I have just moved the hub right next to the dimmer, < 5 ft no walls. same thing.

I also noticed this…

I have 2 dimmers in the same gang box. I put hubitat in exclusion mode. I tap one of the dimmers configuration buttons 3 times and both dimmers flash green!

also the homeseer wd200 (2 of them) can unpair and pair over and over again, as well as the one leviton i tried.

ok, after another nuclear reset session and bringing the hubitat hub into the same room as the first device, things paired, then i kept pairing and reparing… things seem to be working. For whatever reason, but HomeSeer and Leviton were able to pair with the hub in its original spot…

I am curious if you’ll have the same problems with the LZW30-SN (switches) vs dimmers. I’m getting z wave issues on the dimmer but not the switch using a homeseer hub.

hrmm, i moved the hub before i got to trying any switches. sorry.

I had hell with one of my Red dimmers. It paired just fine, but I thought I had a driver issue, so I tried to exclude it. Hubitat would not exclude it. Even fired up my ST exclude as it usually works, but did not. I could not exclude or include my new dimmer switch.

Remembering I had initially paired the switch while it was outside the gang box, I thought what the heck. For sh*ts and giggles I removed the trim plate. Low and behold my switch excluded instantly with both Hubitat and ST and it also paired very quickly as well.

Something to try.

that is interesting, i paired my entire house outside the gang box, as I wanted to make sure it all worked before going through all work of closing up everything up. So I wired everything up, left them all hanging by the wires, paired, repaired z-wave network, etc, then put everything into the boxes, repaired the z-wave network a few more times. Things seem stable now as far as the z-wave network is concerned.