Controlling SONOS via red series dimmer


Is there a way to control a SONOS player via the multi-push / multi-held buttons on the red series dimmer ?

IE: If button2 pushed (2x tap on the UP physical button), play a specific station on that room’s SONOS.

I’m using SmartThings’s smart lightning smartapps to activate lights, but the smartlights app won’t let me control anything else than light/switches (ie: sonos).


(BTW, a quick note to Inovelli’s staff: I have just installed my first Inovelli product (red series dimmer) and I must say I’m blown away! I really wish I had discovered this product line before I purchased a bunch of wifi switches (kasa).

There’s a quality feel to the switches, the buttons aren’t flimsy, the LED notification is awesome and it’s packed with features! I’ve read that the project name is “lights out” and offcourse, I’ll be replacing all of my wifi switches with red series dimmer!)

To the dev team: Outstanding job! :smiley:

I think so, with a bit of work. I’m not doing it exactly this way, but you ought to be able to adapt this.

I use Sharptools for dashboards. One of the things that you can do on a dashboard is have a music jukebox where you can press a tile and a particular Pandora channel, for example, will play. Part of this uses the Sharptools Rule Engine to play a preset on Sonos.

In the techique I’m describing (writeup below), the Rule Engine doesn’t have a trigger. Instead the rule is added to the dashboard to that when the tile is pressed, the channel plays. But it seems to me that there isn’t any reason that the rule engine couldn’t use a button from the Inovelli as a trigger.

This is off the top of my head, but it may get you started down the right path.

Tagging @josh .

1 Like

Pointing toward Sharptools was a good idea. I already have a premium Sharptools account.

I managed to get it working this way.

I added my station to my Sonos preset list (id=1)

I created a virtual switch in SmartThings called “Play Radio”.

In Sharptools, I made a rule that says WHEN Play Radio is ON, execute “playPreset (0)” on SONOS, then turn off the Play Radio virtual switch.

Works perfectly! :smiley:


Thanks for the tag @Bry and thanks for sharing your solution @mickael18! Glad to hear you got it working! :smiley: