[DEVICE PAGE] Inovelli 4-in-1 motion sensor LZW60

@EricM_Inovelli I am also unable to get my LZW60 to report any battery level other than 0% with Home Assistant. I’ve got it on FW: 2.5 and have tried excluding/re-pairing, refreshing, etc. Do you currently think this is a firmware bug? If so, any guesstimate on when a new version will be released to try out? I reached out to your support team, but they suggested I check with the forums instead…

1 Like

Any issues with this product being added to Hubitat c7? I have a competitor 4-1 sensor that pairs but bogs down the mesh after about a week to the point where hub needs to be restarted. I reached out to their support and was told that issue is with S0 and C7’s 700series chip and that I needed to get a 500 zwave chip stick to add in S0 to Hubitat C7. I don’t want to into that issue or plan on getting an additional stick.

It should pair fine with the C7. You might want to disable S2 & S0 during the inclusion to improve performance. There should be a pop-up during inclusion with check boxes.

Not to sidetrack this, and the Inovelli sensor is good, but this is unlikely to be exactly what Zo…err, the other company’s…support said, or at least what they meant. :slight_smile: You just need a secondary controller (any generation is fine, even 700-series) and you want to avoid S0, not pair with S0. This is a similar issue to what Inovelli had with their smart bulbs, which they’ve recently-ish released firmware updates to address by allowing a pairing method that should avoid S0, though the secondary controller method still works.

Recent Hubitat firmware just replaced this with a “Confirm” button (which will use the default grants) or a “Skip” button (which should avoid all S2 and S0, assuming the device supports S2 in the first place so you even get this prompt) — no checkboxes anymore. But same idea. :smiley:

1 Like

Techsupport:
This is an issue specific to the Hubitat C-7 platform which doesn’t allow non-secure inclusion for S0 devices. There’s currently nothing we know of that could possibly address the problems on the device side but we’re actively looking for other solutions to this issue.

The only known workaround is to use a 500 chip Z-Wave stick, add it as a secondary controller to Hubitat, and then use PC Controller to add the sensor without security to the network.

I misunderstood the support’s answer. I attempted to exclude/include the sensors again and hubitat didn’t bring up the check “confirm” or “skip” buttons. it automatically add it as s0. I am probably going to resale the sensors and buy inovelli’s 4-in-1 if it doesn’t have the same issue.

That much is correct; if the device supports S0 but not S2, you will not see the prompt. Their claim that there is “nothing they can do” on the sensor side isn’t 100% accurate: they could release new firmware that only uses S0 if you put it into a special “secure pairing mode,” i.e., allow non-secure pairing with a different set of steps. That is what lots of manufacturers did since the beginning, and it’s what Inovelli added to their bulbs. Whether it’s possible for them to do this (space constraints, technical or human resource issues, etc.), I don’t know — but they’re unlikely to address it in any other way than they already have (just recently, in case you haven’t seen): releasing a new 700-series version of the sensor that supports S2 and lets you choose. :slight_smile: You also don’t need a 500-series secondary controller; it’s security that’s the issue (only comes up with Hubitat because they’re using the official SiLabs Z-Wave 700 SDK, which works this way; PC Controller, for example, doesn’t).

That it does not, so you’ll be good! It supports S2, so during pairing, you can choose to use S2 (this is the “Confirm” button now) or no security (this is the “Skip” button now). Honestly, I haven’t had a problem either way, but some people do suggest avoiding all security during pairing if you don’t care one way or the other.

Does anyone know what the firmware changes were from 2.3 to 2.4? I just received a couple refurb sensors that are running 2.3, not sure if I need to update. I only see details of the change from 2.4 to 2.5 which adds the option to set it up as a repeater, which I don’t need.

2.4 had a bug fix that only a few people experienced. The sensor would stop reporting after some time. 2.5 adds the ability to include the sensor with repeater capability. I’ve ran most of my sensors off of 2.3 for almost 2 years with no problems. I don’t plan on updating them.

Is there any chance of expanding on the Zwave association options for this sensor in the future? Specifically, it would be nice to have the option to trigger the basic set for group 2 only when motion is cleared and only when motion is detected (Aeotec Trisensor has these capabilities for Zwave association). Also, an additional association group that is triggered when there is motion AND light is above a certain value. Is this a possibility? I currently achieve this using automations in Home Assistant, but direct Zwave association is nice to avoid the lag and have the light turn on instantly when motion is detected.

1 Like

This should already be available via param 14. Should be group 2.

Yes, but for comparison, here are the options available on the Aeotec Trisensor for the Group 2 basic set, it would be nice if the Inovelli senor offered the same:
image

I use option 4 on my Trisensor, it turns off the light when motion clears only, but does not turn on the light when motion is detected (a “vacancy” detector rather than an “occupancy” detector).

1 Like

Oh sorry, mixed you wanted it in clear. Then you want param 15. Reverse basic set behavior.

I’m not familiar with the trisensor. Does it allow you send a basic set on multiple sensor inputs?

1 Like

I ended up flipping all of my lzw60s over to 2.5, and so far it’s been a solid firmware. It does look like they are reading a bit high, but it also look like it’s a somewhat consistent offset. Need to move a couple other temperature sensors around to confirm though. Two of them also seem to occasionally just stop sending / responding as well. They are in areas where the extra relaying might not be a big win, so I may back them down to 2.3.

That being said my overall network seems better for having the ones that are relaying working, so I’m pretty pleased!

1 Like

Minor update on this, when they work they work super well and I’d love to see this, however, I’m at the point where all of my LZW60s are definitely randomly just wandering off, not sending updates and becoming un-pingable until power is removed and replaced (on the plus side I’ve been playing with some lovely usb remote switches too). I think I’m going to have to back them down to 2.3 just to get back to being stable though, which is a bummer but I love the idea!

1 Like

I’m having inconsistent reporting by my two LZW60 using SmartThings. One is saying no motion (good routing), the other is stuck on motion (hitting ghost nodes??). Both USB powered. Both 2.03 firmware. Both in close-ish proximity other powered wave plus devices. Temp and humidity seem ok but I have not verified, Just trying to get them to work.

Tried including, excluding, factory reset. Also can’t seem to get a full read of the firmware on PC Controller 5 which is interesting. I try to “get firmware” and it’s blank so firmware values are from SmartThings.

Do I fit in that category of needing 2.4? And…how do I do it?

Hmmmm, I haven’t seen that issue before. Are you using our latest device handler?

As for the update, you usually have to “get firmware” and then triple click on the button to wake it up. This will report the firmware level. Then you start the firmware update process and triple click again on the button.

If you’re using it exclusively as a vacancy sensor, then the additional latency from a round-trip to home assistant seems totally irrelevant. Who cares if the light turns off 5 minutes and 900 milliseconds after motion stops, vs 5 minutes and 200 milliseconds?

For events in response to motion starting, though, latency certainly matters.

There was a crippling bug in the 700 series controller firmware from Silicon Labs (the one every manufacturer’s hub/stick is based on), that under certain conditions totally bogged down your network. It took a long time, but Silicon Labs finally fixed it, and released updated firmware, so if you’re still experiencing issues, try a firmware update for your controller.

1 Like