Dimming of LZW31-SN

Is 45% the highest minimum dimming that is allowed via the app?

I would like to know also. It would appear that 48% may work best for my lights. If from an off state, to 47%, one out of four lights are dimmed (the rest are off). When going from an off state to 48% all the lights turn on dimmed.

So maybe 47% would work great even.

From going from an off state to 1% - 46%, all my lights are off. I understand there is a minimum dimming level set, which I have a request into support to help with that (it appears setting this at the paddle is mis-documented as described by other posts).

Timely thread, just ordered and installed one of these and I notice that below around 37 (%) the light switches off.
in the zwave parameters i have;

Minimum Level: 1
Maximum Level: 99

The scale also seems a little skewed too. 37 - 70 seems to be where the adjustment occurs. Below 37 is off, and above 70 seems full brightness.

I’m using OpenZWave 1.6 (Zwave2MQTT and HomeAssistant, but this test was all done in Z2M)

It’s not really “the app” (not sure what hub, platform, or app you’re even using). Assuming the documentation is accurate, it’s just a limitation of the device itself. The minimum dim level is Z-Wave parameter 5 and accepts a 1-byte value between 1 and 45 (corresponding to percentage) with a default value of 1. Perhaps they could consider increasing this in a future version, but it would take a firmware update to the device itself (I’m not sure why the current limit exists; it could be a storage or resource constraint on the device itself — they’re pushing a lot of limits from what I’ve read — but it could just be a usually-reasonable design decision and perhaps a desire to not conflict with the range of the corresponding “maximum” parameter).

Do note that with at least the SmartThings DTH and Hubitat drivers (not sure how this is handled on other platforms, but I’d guess it’s similar), you’ll still see dimming ranges of 1-99 (or 1-100 if your platform treats the Z-Wave maximum of 99 as such), regardless of the parameter 5 (minimum level) setting. So, if you’ve already changed this parameter and are trying to figure out your new “real” minimum dim level, you might want to temporary un-do this parameter (set it back to 1) so you can see the “real” level without needing to do arithmetic to approximate its “real” value.

Different bulbs will also respond differently to different parts of this range — e.g., some may dim a lot between one or two percentages at lower levels but have barely perceptible differences with the same percentage of difference at higher levels (or vice versa, but that’s really usually the way I’ve seen it). I don’t have a lot of these controlling “real” bulbs, but it’s something I’ve just gotten used to for the most part (imagine me saying “I know my light bulbs” as I’m dimming like someone who says “I know my car” as they’re getting dangerously close to “E” :laughing: — though I think I’ve figured out the best parameter 5 settings that gets me low levels without the bulbs actually turning off, so far, so switch operations — this is easy to accommodate on the hub side for me — generally aren’t dangerous).

thanks for the very detailed reply!

My challenge is the parameter is default and seemingly anything below 37 is either off or past the realm of human sight at that point?
38 is a very very dim glow
71 up to 99 is as bright as 70

so my issue is somewhere in the process the scaling is out of whack, it could be the bulb (unlikely) its more likely the switch.
i’m using zwave2mqtt. So I essentially send a direct command which is relayed to the switch.

The fix for this was in fact to change the parameters
Minimum level = 38
Maximum level = 70

Now when i send 1 - its on dimly
and when I send 99 its on
and somewhere the scaling is done in between

I was worried for a second that my reply was to you, in which case I could have saved you a bunch of reading if I knew that you didn’t already try that. :laughing: Mine was in response to the OP’s question about these parameters, but I’m glad you found them in any case! I have to do something similar on mine. I suspect LED bulbs in particular vary quite a bit here in what settings they’ll work best with here.

My answer for this is still true, but I think I read somewhere that they would consider upping this a bit — their main goal was, as suspected, just not to let the minimum level vs. maximum level settings collide/cross. Of course, I can’t find that post now… (and I don’t see it in the firmware beta they’ve already got out, so if under consideration at all it would likely be in another future release instead).

1 Like