Dimming Speed and Ramp Rate (Parameter1 and Parameter3) are swapped - FIXED IN 2020-08-12 DRIVER

I found what I believe to be a bug with Ramp Rate/Dimming parameters in the Red Series Dimmer (probably also for the Black dimmer but I don’t have any of those to check)

After extensive trial-and-error I have discovered that Parameter1 and Parameter3 seem to be swapped. In other words, Param1 description says it controls the “Dimming Speed” used with zwave dimming up or down. But what it actually controls is the “Ramp Rate” which is used with zwave ON or OFF. Likewise, Param3 description says it controls the “Ramp Rate” but what it actually controls is the “Dimming Speed”.

So it appears that these two parameters are swapped from what the descriptions say. Due to the logical order of the descriptions I would guess that the swap error is in the firmware. However, its a relatively easy workaround to swap the descriptions in the device handler. I’m only speculating, but this might affect all Red and Black dimmers across all hub platforms. I only have Red dimmers with SmartThings so that is all I could confirm this behavior

As coded in the ST DTH dated 2020-05-06:

Param 1 Dimming Speed [via zwave]
Param 2 Dimming Speed at physical switch
Param 3 Ramp Rate [via zwave]
Param 4 Ramp Rate physical switch

What actually happens:

Param 1 Ramp Rate [via zwave]
Param 2 Dimming Speed at physical switch
Param 3 Dimming Speed [via zwave]
Param 4 Ramp Rate physical switch

3 Likes

I’ve also often wondered about this… Glad someone took the initiative to actually test it!

I use Home Assistant with a number of red series dimmers and I believe I have observed the same.

My configuration objective is to have “as close to instant as possible” on/off behavior from local single taps and zwave on/off actions, with the only delay being local dimming rate to allow for local dimming by holding the paddle up or down. To accomplish this, I should be able to set parameters 3 and 4 to 0, per the documentation, but have always found that I need to set parameter 1 to 0 as well. I assumed this was some bug with the interaction between Home Assistant and OpenZwave with respect to sending a “dim to 100/0” vs “turn on/off” message, and shrugged it off, but learning that these parameters may be genuinely backward turns on a mental lightbulb (:bulb:) with respect to explaining my past experiences configuring my dimmers :slight_smile:

1 Like

Yep, my objective is similar. I want the on/off events (whether local paddle or via zwave) to be almost instant but the dimming events (whether local paddle or via zwave) to have a little bit of fading up/down (instead of a quick jump). Dimming rate at the switch, needs to have some rate (1 or more) or else it just jumps from min-to-max or max-to-min. Dimming Rate via zwave is a personal preference.

To do what you want (all events to act almost instantly except for local dimming at the switch) you will need to set these values:
Param1 = 0 (instant on/off via zwave command)
Param2 = 1 (or higher to have slower dim rate with paddle switch)
Param3 = 0 (instant jump to dim level via zwave command)
Param4 = 0 (instant on/off via paddle switch)

To do what I want (all on/off events to act almost instantly and all dimming events to have slight dimming rate) I set these values
Param1 = 0 (instant on/off via zwave command)
Param2 = 1 (quick fading when dimming via paddle switch)
Param3 = 1 (quick fading when dimming via zwave command)
Param4 = 0 (instant on/off via paddle switch)

@EricM_Inovelli

I just loaded the new 1.47 firmware with the newest (2020-08-07) Device Handler and see this problem still exists. Its an easy fix to edit the descriptions in the Device Handler (swap the text description between Param1 and Param3). I can edit mine manually, but it really needs to be updated in the Device Handler that Inovelli distributes.

@mamber thanks for pointing this out. :wink:

Actually, what is going on is the commands are swapped inside the device handler. The on / off should send a basicSet and the set level should send a switchMultiLevel. I’ll change that so the parameter descriptions are correct.

1 Like

@EricM_Inovelli

Do the Red Series Dimmers honor the Hubitat’s fade time on a Dim command?

@robstitt Yes, it should. I just checked the driver and if setLevel is used with a duration, it will use the duration in place of what is set in the parameters.

1 Like

I’ve been testing this on firmware 1.52. I find it very confusing. It appears that all of the settings are based around parameter 1? So for example if you set parameter 1 from default of “3” to “0”. Everything dimms from both the paddle, and z-wave instantly. It would be nice to have clearer documentation on how each parameter works.

I can set parameter 1 to “3” and parameter 4 to “0” and that seems to cause the paddle to do instant on and off.

If I set parameter 1 to “0”, and parameter 4 to “101”, and then try to dim from a paddle it is instant dimming.

The DEFAULT setting for parameters 2-4 is 101 which means they will track the setting in Parameter 1. So yes, by DEFAULT, setting parameter 1 will do the same for 2-4 also.

If you want parameters 2-4 to behave differently than parameter 1 then all you have to do is change parameters 2-4 to the desired value (something in the 1-3 range usually) then each one will behave independently

This is displayed in the device settings page, and seems pretty clear to me :thinking:

  1. Dimming Speed This changes the speed in which the attached light dims up or down. A setting of 0 should turn the light immediately on or off (almost like an on/off switch). Increasing the value should slow down the transition speed. Range: 0…100 Default: 3

  2. Dimming Speed (From Switch) This changes the speed in which the attached light dims up or down when controlled from the physical switch. A setting of 0 should turn the light immediately on or off (almost like an on/off switch). Increasing the value should slow down the transition speed. A setting of 101 should keep this in sync with parameter 1. Range: 0…101 Default: 101

  3. Ramp Rate This changes the speed in which the attached light turns on or off. For example, when a user sends the switch a basicSet(value: 0xFF) or basicSet(value: 0x00), this is the speed in which those actions take place. A setting of 0 should turn the light immediately on or off (almost like an on/off switch). Increasing the value should slow down the transition speed. A setting of 101 should keep this in sync with parameter 1. Range: 0…101 Default: 101

  4. Ramp Rate (From Switch) This changes the speed in which the attached light turns on or off from the physical switch. For example, when a user presses the up or down button, this is the speed in which those actions take place. A setting of 0 should turn the light immediately on or off (almost like an on/off switch). Increasing the value should slow down the transition speed. A setting of 101 should keep this in sync with parameter 1. Range: 0…101 Default: 101

Hmmm. Yes, I’ve read the descriptions. If you take a look at the description for parameter 3. “A setting of 0 should turn the light immediately on or off (almost like an on/off switch)”

If I only adjust the parameter 3, (Ramp Rate), to “0” and don’t touch any other parameters. Then send it a z-wave off or on command to a light, it doesn’t immediately turn the light on or off like the description says.

Which version of the Device Handler are you using? (It was recently updated on 3/10/2021) If you look at the very first post in this topic I described how some of the parameters were swapped compared with their descriptions. The fix for that was an updated device handler. If you’re using the original device handler then parameter 3 was setting the zwave dimming speed instead of the zwave ramp rate. (which could explain what you are seeing)

The first thing you should do is download the latest device driver from the Inovelli website and load that into your hub and then make sure your Inovelli switches are configued to use the newest device driver
https://support.inovelli.com/portal/en/kb/inovelli/downloads/code

If you are using Hubitat, I suggest using the Hubitat Package Manager App which will keep you updated with the latest Inovelli drivers when they are released

Hmmm. I’m using the latest openzwave device xml file with Home Assistant. open-zwave/lzw31-sn.xml at master · OpenZWave/open-zwave · GitHub

Going back to what you have above this is what seems to be working best for me:
Param1 = 1 (instant on/off via zwave command)
Param2 = 3 (quick fading when dimming via paddle switch)
Param3 = 1 (quick fading when dimming via zwave command)
Param4 = 1 (instant on/off via paddle switch)

I think the primary thing I was confused about, is I thought I could leave parameter 2 at 101, and that would still give me about 3 seconds to dim the light from the paddle, but I actually had to set it to 3 for that after changing parameter 1.

If any of the parameters 2-4 are left at 101, they will sync with whatever you set in parameter 1. Since you changed parameter 1 and left paramter 2 at 101 it is going to match what you set in 1.

Also, the list you quoted from me was the OLD and INCORRECT behavior in the old drivers (which has been fixed in the current drivers).

The correct descriptions are:
Param1 = dimming speed via zwave command
Param2 = dimming speed via paddle switch
Param3 = on/off ramp rate via zwave command
Param4 = on/off ramp rate via paddle switch

Not sure exactly what your end goal is, but if you want instant on/off (no ramping) but keep the default 3-second dimming, then you would leave Params1-2 at default and change Params3-4 to 0