Disable Dimming Functionality?

I’m wondering if there’s a way to disable dimming functionality at the switch on any of the no-neutral switch options. This has probably been asked but I couldn’t locate a thread for it. I understand that the non-dimmers need a neutral. I’m just thinking that if the dimmer could be programmed to simply not dim (min and max dim levels at 100% or just disable the buttons) then it would just be a straightforward on/off switch that doesn’t need a neutral. Is that an option?

Secondary question. Does/can the LED work as a straightforward switch status light? On when lights are on and off when lights are off (or similar)?

I need a no-neutral on/off that controls a light that’s out of sight from the switch and need to be able to look at the switch to see if the power is on or off.

Go into settings and turn on Smart Bulb Mode. It will power the bulb at full brightness and won’t dim, effectively making it like a switch.


Also set parameters 1-4 to 0

1 Like

Will this work with regular (not smart) bulbs? I was assuming that Smart Bulb Mode was mostly just to act as a remote for the smart bulb. Otherwise, turning the switch off would cut power to the smart bulb and it wouldn’t turn back on… smartly.

Yep, I’ve done it with CFL and incandescent. it’s just a voltage thing.

1 Like

Awesome! Thank you! Any input on my other question? Can you set the status light to show on/off just by looking at the switch? I’m controlling a set of lights completely out of sight of the switch, so I need to know I’m turning them on and not off.

Couldn’t find it in writing anywhere but watched a video review and answered my own question about the switch status indicator. (Yes). Thanks again for your input!

Glad you found it. I find that when you put the dimmer in the the Smart Bulb Mode, the LED will to some extent still work like a dimmer. So when you first press up to turn the bulb on, the bulb will be at full brightness, but the LED indication will remain at whatever it was the last time you turned it off.

So with the bulb on, a long press on the dimmer will get the LED to full illumination. Once it’s there, short presses on and off turn the LED indicator either completely off or at full indication. However, if you do a long press, the LED will still act like a dimmer and vary it’s display, even though the bulb remains at full brightness.

I haven’t played with parameters 1-4 that @stu1811 mentioned. He might be able to shed some light on wheter or not those settings can keep the LED level from varying when the Smart Bulb Mode is on.

Parameters 1-4 control ramp and dimming speed. Setting to zero makes the switch behave like an on/off switch.

Yes, but that’s not what the OP is asking. He wants to know about how the LED behaves when it’s in the Smart Bulb Mode. I explained in my post about how it acts and was wondering if tweaking parameters 1 - 4 made the LED more switch-like.

I took this to mean use a dimmer in non neutral as on off switch

Yes, that’s right. If you look at my post above I explained how the dimmer’s LED still sort of works like a dimmer varying the LED illumination even though the bulb is on full brightness. You mentioned tweaking parameters 1 - 4. I didn’t test that. Do your settings help the LED illumination act more like a switch or will the LED still vary like it’s a dimmer even with those settings?

Since you’ve enabled those parameters, I though you could check real quick.

Tap up or dimming up results in full brightness. I have this configured on my test bench.

I follow the logic of changing the parameters to minimize fade in/out and that the LED brightness will still dim/brighten based on the summer function even if the bulb doesn’t. Seems like this would do the trick for me.

FYI setting parameters 1-4 made the on/off functionality exactly what I needed. I really appreciate that too.

For anyone who may find this thread in the future, I struggled a little with setting the parameters at the switch. I didn’t feel like the instructions I could find made me feel confident about exactly what to press I did it through the Smartthings app and it was easy with little room for doubt.

Hello… you can’t cripple a dimmer (a standard dimmer or an Insteon dimmer), so you ought to consistently coordinate the heap type to the switch type- - non-dimmable burdens should utilize a hand-off style switch and dimmable burdens can utilize either a triac-based switch or a hand-off style one. It is extremely unlikely to keep somebody from holding down a control and causing a dimmer change set to turn all out to change to a diffrent level, and even at full on I think the triac yield varies from a hand-off’s yield in light of the fact that a dimmer is as yet conveying ‘cuts’ of the 60 hertz power gracefully.

I don’t understand what any of that means. I can say the the suggestion above result in an immediate on/off. Yes, perhaps someone hods the dimmer down and it abruptly dims to off instead of turning off, but I assume the end result there is the same.

I came across this post searching for the same answer. I have several locations that require non-neutral switches, however the connected lights are regular (not smart) and non-dimmable lights. While this thread got me close, it still took some trial and error to figure out completely.

After updating my switch to the 1.48 firmware, I tried using Smart Bulb Mode. This did disable dimming, however it also disabled local control of the relay. In other words, the lights were always on and could no longer be turned off using the switch on the wall. :slightly_frowning_face:

Almost what I wanted, however setting parameters 1-2 to 0 just make the lights dim instantly. I don’t want them to dim at all.

So here’s what I’m currently testing and so far seems to be working :slightly_smiling_face:

Parameters 1-2 set to 100 – This controls the dimming speed, that is how fast or slow the light dims. I don’t want the light to dim at all. So setting this to the highest number possible, slows the dimming effect as much as possible.

Parameters 3-4 set to 0 – This controls the ramp rate, that is how fast or slow the light turns on/off. As noted in the manual, 0 = Instant On / Off

I also set parameters 9-10 to 99 – This sets the default brightness, this ensures that the light is always turned on with full brightness. (just in case it dimmed somehow)

I feel fairly confident that setting parameters 1-2 to 100 is effectively disabling the dimming. Even if it’s still happening very slowly, the rate is so slow, it will prevent any significant amount of dimming by accident.

I’ve tested holding down on the switch for various amounts of time, up to ~6 seconds. Sometimes I notice a slight flicker after a few seconds, but the light (and the LED status bar) remains a full brightness. If I hold the down on the switch longer than 4 seconds, the light will just shutoff instantly when released.

It shouldn’t have. Disable Local Control is a separate setting. Make sure it didn’t get turned on as well. I’m on 1.47, but 1.48 shouldn’t make a difference as the change between the two has nothing to do with this issue.

To me, you shouldn’t have to tweak the other parameters. Turning on the Smart Bulb Mode for me works just fine without discernable delay. I know I asked Stu about why he suggested that but never got an answer I understood.

I never set it to smart bulb mode. I only changed parameters 1-4 as suggested above and it’s working how I was hoping it would.