Disable Internal Relay Won't Work?

I recently installed my Red series switch as a single switch in a room. The switch usually controls a couple outlets, but I am wanting to use it to control 3 Z-Wave lights (RGB Yeelights). I can program the switch fine within Hubitat, but for some reason I cannot disable the internal relay… I’ve tried doing it manually (pressing config button 8 times) and disabling it within Hubitat. Seems no matter what I do pressing the switch off cuts off power to the outlets/switch…

Ideally I want power always on through the switch (to the outlets) and only use the switch to toggle actions via Hubitat. Not sure if I wired something wrong or what - though everything works correctly otherwise…

Appreciate any help! Thanks!

(I followed the install instructions from Inovelli and am using their driver via Github.)

Did you press the config button eight times really fast? It does take me a couple times and have to ensure I am tapping it at the speed of light while counting to eight.

1 Like

Just to add on to what James said - when you press it 8x, the LED bar should flash Red to indicate it successfully disabled local control.

When you press it 8x, does the LED bar flash a certain color?

1 Like

Thanks for the quick replies. When I disable it manually like that, it does flash red yeah. Do I need to set it manually and digitally in Hubitat or should one way work?

Next step (should have been first step probably) is to remove it from my Hubitat and reset and readd it. :thinking:

If you do it manually from the switch, that should suffice for disabling the internal relay. You shouldn’t have to do it from Hubitat.

Gotcha. Yeah, seems to not be working when I do it manually or in Hubitat then. I’ll remove and reset it and try again. This is my first go so this could be user error. :sweat_smile:

Is there an order it needs to happen in? Like should I disable it before adding it to my Hubitat or adding actions or anything specific like that?

Thanks again!

Do you have smart bulb mode enabled?

This is what I would do. Add it to the network, turn the switch “on”, press config button 8x, and try to power off. The bulbs should remain on (assuming they turned on when you pressed on.

1 Like

If doing it from Hubitat, then do this:

First: Change to Yes where arrow is.

Then: Save Preferences.

1 Like

Thanks so much for all the help! I was able to get it working!

I removed all rules and then removed and added the switch back to my Hubitat. I followed the order listed above: added switch to Hubitat, disabled internal relay manually, then checked the switch and re-added my rules. It works now! Must have been user error my first few attempts somewhere, or maybe I started building rules and such before ensuring the switch was set-up right. :man_shrugging:

Either way, it is working now and is amazing! Thanks for the quick help! Really love this switch, so much power! Thanks again!!