Disable local control or smart bulb mode?

I have recently migrated to Home Assistant from Hubitat. When I had one of my Black Series switches connected to Hubitat, I used it essentially just as a smart switch, where the power to the light bulbs is always on, no matter what button is pressed. It just toggled on/off the smart light bulbs that were connected. I have managed to lose that configuration in the swap over to Home Assistant, and I’m just trying to get it back.

There are two options in the Z-wave configuration which seem likely, but neither seems to be doing what I am looking for. In Home Assistant, I can go to “Configure Device” in ZWave JS, and set the different Z-wave parameters. The two settings I’m looking at are Parameter 12 (“Association Behavior: Local”) and Parameter 52 (“Smart Bulb Mode”). If I turn OFF Parameter 12, I would expect local control of the power to the light bulbs to be disabled. But the switch still turns power to the lights on/off. So I tried turning ON Parameter 52 “Smart Bulb Mode,” but no luck there either.

What is the proper configuration of the switch so that power to the light bulbs is never turned off, but I can use the switch buttons as scene controllers to turn the smart light bulbs on/off using an automation in Home Assistant?

You could always enable Smart Bulb mode and then go press the config button 8x to disable local control.

1 Like

Smart bulb mode 2. Always on load. Then use the LZW31-SN blueprint to light.turn_on when up is pushed and light.turn_off when down is pushed.

Easy peasy.

Disable local control not needed.

Tried the 8x click option and now local control is disabled! Thanks!

I am curious about smart bulb mode 2, though. How would I turn that on? The configuration interface for the device in HA just has an on/off switch for Smart Bulb Mode - I don’t see anywhere to set a mode.

Under z-wave device page, select configure, then you should see this under parameter 52 if you have the latest firmware loaded (non-beta or beta both have this feature).

I find that automations are just as reliable as with Hubitat, but noticeably faster. Nothing was really wrong with Hubitat, though - I’m just more of a tinkerer and wanted ultimate control, which HA gives me. Sure, there are times when I wanted to rip my hair out, but ultimately everything that hasn’t worked has had an explanation and a solution - some have just taken longer to figure out than others. For my Inovelli switches, I actually upgraded firmware and then downgraded the firmware back to 1.52 beta so that I could get control of the Scene buttons (maybe this is available in a later beta too, but 1.52 was working great for me with Hubitat, and it’s working now for HA too). I’m happy with the move to HA, though.

1 Like